summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-core-libs
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-core-libs')
-rw-r--r--gnome-base/gnome-core-libs/Manifest1
-rw-r--r--gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-base/gnome-core-libs/Manifest b/gnome-base/gnome-core-libs/Manifest
index 913d40ff4cf0..38595270c635 100644
--- a/gnome-base/gnome-core-libs/Manifest
+++ b/gnome-base/gnome-core-libs/Manifest
@@ -1,2 +1,3 @@
EBUILD gnome-core-libs-3.30.2.ebuild 1153 BLAKE2B 33d95d463dd035be5025a64f4cad3760b29fed14d53af7b1ce02ed4e272f4542ec7522bd0df9deec24a0ab1b0a67da270578f336b3fdd246cb53198118d4152a SHA512 cf220028cf5c89287955faa0d06d4e6592d31ef3824d85a3c3d262c2a056bd537d674ea3a260643a9d5eaf87deaa6438d0d5448d29f6cf27a4dfce6ab59ef7f2
+EBUILD gnome-core-libs-3.32.2.ebuild 1166 BLAKE2B 7c627259c1d9a44b07b9b561bbad19372c963639be937116cd2f8d3aced61df9bc9d86170e647df858e0d7f3fab58d39facc0ccbb09d28aac2f11c0c0503c222 SHA512 9ce3a671364c45aa559b6fc3c9625c9d3cc5446b57252504c2396e8699a64dffd8f62f57d8f7e1cfb360214667a11f2bc16c639161c3c41215290c83b1e1510d
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild b/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild
new file mode 100644
index 000000000000..5fdcc803674c
--- /dev/null
+++ b/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Sub-meta package for the core libraries of GNOME 3"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="cups python"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Note to developers:
+# This is a wrapper for the core libraries used by GNOME 3
+RDEPEND="
+ >=dev-libs/glib-2.60.2:2
+ >=x11-libs/gdk-pixbuf-2.38.1:2
+ >=x11-libs/pango-1.42.4
+ >=x11-libs/gtk+-3.24.8:3[cups?]
+ >=dev-libs/atk-2.32.0
+ >=gnome-base/librsvg-2.40.20
+ >=gnome-base/gnome-desktop-${PV}:3
+ >=x11-libs/startup-notification-0.12
+
+ >=gnome-base/gvfs-1.40.1
+ >=gnome-base/dconf-0.32.0
+
+ >=media-libs/gstreamer-1.14.4:1.0
+ >=media-libs/gst-plugins-base-1.14.4:1.0
+ >=media-libs/gst-plugins-good-1.14.4:1.0
+
+ python? ( >=dev-python/pygobject-3.32.1:3 )
+"
+DEPEND=""
+BDEPEND=""
+
+# >=x11-libs/libwnck-3.24.1:3 - not used by core packages anymore
+# librsvg kept back on non-rust version; should move on at some point for non-exotic arches.
+
+S="${WORKDIR}"