summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7906 -> 7907 bytes
-rw-r--r--games-util/lgogdownloader/Manifest4
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild11
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild12
4 files changed, 21 insertions, 6 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 1eac1a645503..dad4b3709c2a 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index f522242f023d..ae367a18fc88 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1,4 +1,4 @@
DIST lgogdownloader-3.16.tar.gz 105119 BLAKE2B 4b181bf6b5b81503610cc45273fc014f535c8ed0dec686dd419db3cd2dea364b7d53692420986d16a227d955fecae012f1643ab6dbd4ed10a798d18cf883685d SHA512 09c4b851a4589e67d78ac530886c9700f997b711199ff003f35296463e5e877d0f84d5f4a2507627ee35e8cf351808f2d7c53288727c5e9e84c8401ff2215eb3
-EBUILD lgogdownloader-3.16-r1.ebuild 864 BLAKE2B 7d97e1657e0f37dca1868d73585b60b53a7d121a5302456835da799c021fc82423de56dfd98ce062645b7a62f8500a2c0a794dfd7e015d1798bc6502ab907f7b SHA512 72aee3e5056545a00733c61749727ef646c89e891ed2ded7761fc579f7887c9b8450f3f1206308c7e2e0b9535419fabdcf81dbb75320b412d6c4654a9309b034
-EBUILD lgogdownloader-9999.ebuild 830 BLAKE2B b7c2aebb68a4ace24d0ea45877f0639bd229c9f0bb7471fc55bfff1a9f1e5a0cc7fd5c494d7d21ef7d8678b774693071a3bff771aa01a1132165f2fe0a34ef92 SHA512 5866b4449db37c900596f20daccf61229457d59851a83ec0e78f62f4e6b06529f1bbd22fe4d503cdfe150ba0d895db52b5b350e72d2d1d09e84e44fa9819c34d
+EBUILD lgogdownloader-3.16-r1.ebuild 1000 BLAKE2B 1b893fc627269ed419a4e08c718ba88373c358bdb9e2c03a4f37b860227e62fdc2b77dcc7b47660c10946c21decfd47b67e4a50321b89389bc9e3ba2bcc2cb25 SHA512 f2554b38121ad156081f61a34411a2ff5d3bfe83df7a9161bbe89eb201b27b2bb6e61416c1c89dc78e72e287f9d1ac0e1ae93c53345f00b24d2188019dc8889c
+EBUILD lgogdownloader-9999.ebuild 1000 BLAKE2B 1b893fc627269ed419a4e08c718ba88373c358bdb9e2c03a4f37b860227e62fdc2b77dcc7b47660c10946c21decfd47b67e4a50321b89389bc9e3ba2bcc2cb25 SHA512 f2554b38121ad156081f61a34411a2ff5d3bfe83df7a9161bbe89eb201b27b2bb6e61416c1c89dc78e72e287f9d1ac0e1ae93c53345f00b24d2188019dc8889c
MISC metadata.xml 1098 BLAKE2B 154a5ed56c5e935723180acca12ae6e0a14ee2353b1a1626e16e1932922121b8d4b5eb6b5e1f2ade2f707eff696f744677e7d8f9059cdfd6f1357c77a6dc3196 SHA512 b28a6adab900d56756f206983b4fc39f5b0158702cc7a053d4c6a60f926d0dfd5d2853e0df7e99684891d7b6451829b3908c3fe9ff6a320d4fcf51c0910d417e
diff --git a/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild b/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
index 384ea18d90ab..77314984dd49 100644
--- a/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-3.16-r1.ebuild
@@ -5,13 +5,19 @@ EAPI=8
inherit cmake
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="WTFPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="gui"
RDEPEND="
@@ -32,6 +38,7 @@ DEPEND="
"
BDEPEND="
+ dev-qt/qtbase:6
virtual/pkgconfig
"
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index 74f57ee662f9..77314984dd49 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -3,11 +3,18 @@
EAPI=8
-inherit cmake git-r3
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
LICENSE="WTFPL-2"
SLOT="0"
@@ -31,6 +38,7 @@ DEPEND="
"
BDEPEND="
+ dev-qt/qtbase:6
virtual/pkgconfig
"