summaryrefslogtreecommitdiff
path: root/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild')
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild
new file mode 100644
index 000000000000..99400f1e5eea
--- /dev/null
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit desktop wxwidgets
+
+DESCRIPTION="Program to decode .CHT files in Snes9x and ZSNES to plain text"
+HOMEPAGE="https://games.technoplaza.net/chtdecoder/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND=${RDEPEND}
+
+PATCHES=( "${FILESDIR}"/${P}-wxgtk.patch )
+
+src_configure() {
+ setup-wxwidgets
+ econf --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ dobin source/wxchtdecoder
+ dodoc docs/wxchtdecoder.txt
+ make_desktop_entry ${PN} wxCHTDecoder application-vnd.nintendo.snes.rom
+}