summaryrefslogtreecommitdiff
path: root/games-util/wit/wit-3.02a.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/wit/wit-3.02a.ebuild')
-rw-r--r--games-util/wit/wit-3.02a.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-util/wit/wit-3.02a.ebuild b/games-util/wit/wit-3.02a.ebuild
index 95c5351036aa..aaeaa614fd02 100644
--- a/games-util/wit/wit-3.02a.ebuild
+++ b/games-util/wit/wit-3.02a.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_P="wiimms-iso-tools.source-${PV}"
@@ -32,6 +32,13 @@ PATCHES=(
)
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/859319
+ #
+ # After investigation, the build system also uses -fno-strict-aliasing
+ # so do not trust it with LTO either, even if the type-mismatch gets fixed.
+ filter-lto
+
export NO_FUSE=$(usex fuse 0 1)
export NO_ZLIB=$(usex zlib 0 1)