summaryrefslogtreecommitdiff
path: root/games-util/qstat
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/qstat')
-rw-r--r--games-util/qstat/Manifest5
-rw-r--r--games-util/qstat/metadata.xml11
-rw-r--r--games-util/qstat/qstat-2.11.ebuild29
-rw-r--r--games-util/qstat/qstat-2.14.ebuild38
4 files changed, 83 insertions, 0 deletions
diff --git a/games-util/qstat/Manifest b/games-util/qstat/Manifest
new file mode 100644
index 000000000000..a4dfc2ac60f9
--- /dev/null
+++ b/games-util/qstat/Manifest
@@ -0,0 +1,5 @@
+DIST qstat-2.11.tar.gz 258335 BLAKE2B f12d0f69c8a73f9eeb273c46aefe2008b8c724b132e02d2fa156c2456f537d2162ae7db6acd0007c7db8bc87dafcfb41355466008c74ce3e912023a7c8cb42cc SHA512 e3ff732c6fc45300eb2f32b3f3e8e1e5f8ee32234535e8d2ca19cf95cf6d4a6de5b6f1e48a5c64315d60a8b388521106b2de9d307f718f6150ad2cf40ba75a22
+DIST qstat-2.14.tar.gz 210440 BLAKE2B 2a33287a69fe63c59a1cb136e84ea29cccd27f4468cb4b38b4e9ce49f28a558dc67793eaa7ead7addd828730e084a15f9684ccba7753852ce1c2795c7c94cb78 SHA512 f2054d74399fe1773a19ca43629e10364fdd87e551459719685c11f38245a05906631b456848b1a3764b4e6843baf654af6a9b174c7b16908b6bcb97ac64c6d6
+EBUILD qstat-2.11.ebuild 677 BLAKE2B d5997ad9bf5dcb6e9e5d689080f2056c310b8924e636e4e1b61d8c7a5362c4dd46301e34ffd11500e01753692af86e897facc2185ad9713ee0fcd7605ea33b03 SHA512 14bd978d242400b4929997011f8c4bb55171504f132400d71d2b4723569385779f0b6d6017675b67a90ffe8418d80ba0a4605c7a71de5b4a3325bc66cc601b95
+EBUILD qstat-2.14.ebuild 775 BLAKE2B d410af9edf50b7a31d5be7d1306db8e9fab011a3cba172b849f842822ed944feda75691335281a038b49b88d8884636d7c092d543993291c6569474b11696dcb SHA512 5b82f8c8182b1c01f9e46fb83fc7ad87a22b34d8c1cb18cea2f8c010202fcec274d9742ecb97eae7b82800eb5ae91fff299c38303854e067c1869ae20fa65a62
+MISC metadata.xml 328 BLAKE2B 05e29df4e66acb89893251aec455d3f05f38344bd12414e74ac46d23573afcd8c7e4d7b2e03d217c443a32e31beaea3d122cd474e317e3490c1d6bbdb7de4c4d SHA512 1f3cbc63b69d59880ff6fe131bf838f69bfd259a93882ef9b38c1d101d4048c2894cf99725d3ce683f9f05da035567d6e4bdafa9d4349844f7b8af98c13f999f
diff --git a/games-util/qstat/metadata.xml b/games-util/qstat/metadata.xml
new file mode 100644
index 000000000000..a8c2e30da965
--- /dev/null
+++ b/games-util/qstat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qstat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/qstat/qstat-2.11.ebuild b/games-util/qstat/qstat-2.11.ebuild
new file mode 100644
index 000000000000..3ec2d6de4ffc
--- /dev/null
+++ b/games-util/qstat/qstat-2.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+DESCRIPTION="Server statics collector supporting many FPS games"
+HOMEPAGE="https://sourceforge.net/projects/qstat/"
+SRC_URI="mirror://sourceforge/qstat/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ppc64 x86"
+IUSE="debug"
+
+DEPEND="!sys-cluster/torque"
+
+src_prepare() {
+ # bug #530952
+ sed -i -e 's/strndup/l_strndup/g' qstat.c || die
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ DOCS="CHANGES.txt COMPILE.txt template/README.txt" default
+ dosym qstat /usr/bin/quakestat
+ dohtml template/*.html qstatdoc.html
+}
diff --git a/games-util/qstat/qstat-2.14.ebuild b/games-util/qstat/qstat-2.14.ebuild
new file mode 100644
index 000000000000..3dbdb38a119f
--- /dev/null
+++ b/games-util/qstat/qstat-2.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Server statics collector supporting many FPS games"
+HOMEPAGE="https://github.com/multiplay/qstat"
+SRC_URI="https://github.com/multiplay/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+IUSE="debug"
+
+DEPEND="!sys-cluster/torque"
+
+DOCS=( CHANGES.txt COMPILE.txt template/README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # bug #530952
+ sed -i -e 's/strndup/l_strndup/g' qstat.c || die
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+ dosym qstat /usr/bin/quakestat
+ docinto html
+ dodoc template/*.html qstatdoc.html
+}