summaryrefslogtreecommitdiff
path: root/games-util/lgogdownloader/lgogdownloader-3.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/lgogdownloader/lgogdownloader-3.7.ebuild')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.7.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-3.7.ebuild b/games-util/lgogdownloader/lgogdownloader-3.7.ebuild
deleted file mode 100644
index fa94c0f4adca..000000000000
--- a/games-util/lgogdownloader/lgogdownloader-3.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Unofficial GOG.com downloader for Linux"
-HOMEPAGE="https://sites.google.com/site/gogdownloader/"
-SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
-LICENSE="WTFPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gui"
-
-RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
- dev-cpp/htmlcxx:0=
- dev-libs/boost:0=
- >=dev-libs/jsoncpp-1.7:0=
- dev-libs/tinyxml2:0=
- >=net-misc/curl-7.32:0=[ssl]
- gui? ( dev-qt/qtwebengine:5=[widgets] )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="sys-apps/help2man
- virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_QT_GUI=$(usex gui)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
-}