summaryrefslogtreecommitdiff
path: root/games-util/higan-purify
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/higan-purify')
-rw-r--r--games-util/higan-purify/Manifest4
-rw-r--r--games-util/higan-purify/files/higan-purify-03-QA.patch42
-rw-r--r--games-util/higan-purify/higan-purify-03.ebuild44
-rw-r--r--games-util/higan-purify/metadata.xml8
4 files changed, 98 insertions, 0 deletions
diff --git a/games-util/higan-purify/Manifest b/games-util/higan-purify/Manifest
new file mode 100644
index 000000000000..4c87e06c40d0
--- /dev/null
+++ b/games-util/higan-purify/Manifest
@@ -0,0 +1,4 @@
+AUX higan-purify-03-QA.patch 1404 BLAKE2B 670d0897fb3d3fb565c36ec30c5dedefdb71bc13770e49a3532059356f3caf652df3a11e00c35e27724ea75e033a248124abca2fc60aa33140d2f858138e39a4 SHA512 31e1fdcd147e75fcaedd1778ef636edc97552fdf520468dd4723112f6557fde0d01a1f476c451e638ca05988543549fa1c76fd83ea70b7f0dbb03a61a4ff02b9
+DIST purify_v03-source.tar.xz 196924 BLAKE2B f4d22ccc34d1c345a2dee20c14bab2614b71b0df2660f3f0883df1b56b5e5fc7fc99872f73ebe674faca8bb455f1a90e5bf79ce9b893f980e99b94546bbcf400 SHA512 095b62013f5a33e720b87c48f32c41239d8cef4c6ddc2b6d119d15b3f8b92bc15d744afa0b2bc8d7a49ef53f8f3fa7f2247be490499a9b194863534f9c1a4b3d
+EBUILD higan-purify-03.ebuild 774 BLAKE2B 09397611fc72e84e516b87f98f7773795bc3273c59d52cc4b68cc6045b8a6e9bcd36af5791ab0cd3bc07701d5c087825ac2a2336c14f69f399e7911051eea093 SHA512 e90d83850caf9f0fa3485763b90652767d8a6eceb5ddcfcc7282a2d6362c24948c02c7434ffbb6f471d7ebb57bc25b1a9685fc58a964a1093e444dff96082598
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-util/higan-purify/files/higan-purify-03-QA.patch b/games-util/higan-purify/files/higan-purify-03-QA.patch
new file mode 100644
index 000000000000..e523ba4cad95
--- /dev/null
+++ b/games-util/higan-purify/files/higan-purify-03-QA.patch
@@ -0,0 +1,42 @@
+--- purify_v03-source/purify/Makefile
++++ purify_v03-source/purify/Makefile
+@@ -2,8 +2,8 @@
+ include phoenix/Makefile
+
+ path := /usr/local/bin
+-flags := -I. -O3 -fomit-frame-pointer
+-link := -s
++flags := -I. $(CXXFLAGS)
++link := $(LDFLAGS)
+ objects := obj/phoenix.o obj/purify.o
+
+ ifeq ($(platform),x)
+@@ -22,7 +22,7 @@
+
+ build: $(objects)
+ ifeq ($(platform),x)
+- $(cpp) -pthread $(link) -o purify $(objects) $(phoenixlink)
++ $(cpp) $(flags) -pthread $(link) -o purify $(objects) $(phoenixlink)
+ else ifeq ($(platform),win)
+ windres phoenix/windows/phoenix.rc obj/phoenix-resource.o
+ $(cpp) -shared -o phoenix.dll obj/phoenix.o $(phoenixlink)
+--- purify_v03-source/purify/phoenix/Makefile
++++ purify_v03-source/purify/phoenix/Makefile
+@@ -4,13 +4,13 @@
+ endif
+
+ ifeq ($(phoenix),gtk)
+- phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0`
+- phoenixlink := `pkg-config --libs gtk+-2.0`
++ phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0 x11`
++ phoenixlink := `pkg-config --libs gtk+-2.0 x11` -ldl
+ endif
+
+ ifeq ($(phoenix),qt)
+- phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui`
+- phoenixlink := `pkg-config --libs QtCore QtGui`
++ phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui x11`
++ phoenixlink := `pkg-config --libs QtCore QtGui x11` -ldl
+ endif
+ else ifeq ($(platform),win)
+ phoenixflags := -DPHOENIX_WINDOWS
diff --git a/games-util/higan-purify/higan-purify-03.ebuild b/games-util/higan-purify/higan-purify-03.ebuild
new file mode 100644
index 000000000000..e9613fa1ec22
--- /dev/null
+++ b/games-util/higan-purify/higan-purify-03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P=purify_v${PV}-source
+
+DESCRIPTION="Rom purifier for higan"
+HOMEPAGE="http://byuu.org/higan/"
+SRC_URI="https://higan.googlecode.com/files/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-games/higan-ananke
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}/purify
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-QA.patch
+ sed -i \
+ -e "/handle/s#/usr/local/lib#/usr/$(get_libdir)#" \
+ nall/dl.hpp || die
+}
+
+src_compile() {
+ emake \
+ platform="x" \
+ compiler="$(tc-getCXX)" \
+ phoenix="gtk"
+}
+
+src_install() {
+ dobin purify
+}
diff --git a/games-util/higan-purify/metadata.xml b/games-util/higan-purify/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-util/higan-purify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>