summaryrefslogtreecommitdiff
path: root/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild')
-rw-r--r--games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild b/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild
new file mode 100644
index 000000000000..d4fd24bff446
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+COMMIT=045774dee7cab1a618a3e0d9b39bff78a12b6efa
+
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/grfcodec"
+SRC_URI="https://github.com/OpenTTD/grfcodec/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ dev-libs/boost
+"
+
+S="${WORKDIR}/grfcodec-${COMMIT}"
+
+src_install() {
+ dobin "${BUILD_DIR}"/{grfcodec,grfid,grfstrip,nforenum}
+ doman docs/*.1
+ dodoc changelog.txt docs/*.txt
+}