summaryrefslogtreecommitdiff
path: root/games-util/gamemode/gamemode-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/gamemode/gamemode-9999.ebuild')
-rw-r--r--games-util/gamemode/gamemode-9999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/games-util/gamemode/gamemode-9999.ebuild b/games-util/gamemode/gamemode-9999.ebuild
index 1c2a2df1c374..9490fc1e7b56 100644
--- a/games-util/gamemode/gamemode-9999.ebuild
+++ b/games-util/gamemode/gamemode-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
@@ -35,6 +35,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7-static-libs.patch
+)
+
DOCS=(
CHANGELOG.md
LICENSE.txt
@@ -76,28 +80,24 @@ pkg_pretend() {
multilib_src_configure() {
local emesonargs=(
- -Dwith-sd-bus-provider=$(usex systemd "systemd" "elogind")
-Dwith-systemd-user-unit-dir="$(systemd_get_userunitdir)"
+ -Dwith-pam-limits-dir="${EPREFIX}"/etc/security/limits.d
)
- if ! multilib_is_native_abi; then
+ if multilib_is_native_abi; then
+ emesonargs+=(
+ -Dwith-sd-bus-provider=$(usex systemd systemd elogind)
+ )
+ else
emesonargs+=(
- -Dwith-examples=false
-Dwith-sd-bus-provider=no-daemon
+ -Dwith-pam-renicing=false
+ -Dwith-examples=false
)
fi
meson_src_configure
}
-multilib_src_install_all() {
- if multilib_is_native_abi; then
- insinto /etc/security/limits.d
- newins - 45-gamemode.conf <<-EOF
- @gamemode - nice -10
- EOF
- fi
-}
-
pkg_postinst() {
elog
elog "GameMode has optional support for adjusting nice and ioprio of games"