summaryrefslogtreecommitdiff
path: root/games-strategy
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/Manifest.gzbin7586 -> 7585 bytes
-rw-r--r--games-strategy/megaglest-data/Manifest2
-rw-r--r--games-strategy/megaglest-data/files/megaglest-data-3.13.0-cmake4.patch24
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.13.0-r1.ebuild33
4 files changed, 59 insertions, 0 deletions
diff --git a/games-strategy/Manifest.gz b/games-strategy/Manifest.gz
index 64fcc56b12c2..6dbe62dd3544 100644
--- a/games-strategy/Manifest.gz
+++ b/games-strategy/Manifest.gz
Binary files differ
diff --git a/games-strategy/megaglest-data/Manifest b/games-strategy/megaglest-data/Manifest
index 13ee6dcf51ac..30e8f4b92748 100644
--- a/games-strategy/megaglest-data/Manifest
+++ b/games-strategy/megaglest-data/Manifest
@@ -1,3 +1,5 @@
+AUX megaglest-data-3.13.0-cmake4.patch 805 BLAKE2B feca9ccab87b93ba573e994d8ae8efbcb07a801fde27b6a66e410850216fb8cf79020966745c93fbeca581792c443ee6d81004365a927af4c5233e4d6c2a5484 SHA512 78714ee73a2b32faa4f609c7b347a8a8d614e26289b407a79f03120bffc1161db6901247acbbb7f6b3450e46d82e277203adb6ea00e02afea218d749a5327524
DIST megaglest-data-3.13.0.tar.xz 291190184 BLAKE2B 369dfb2f9a0271c686b77b4368043717b57e5863f8918afe3cc429c630ed79173c025ad0c5bad1e94949f4caf841b0e3c6706491a8534b829568c7d89ba97383 SHA512 ac6a6dd85ec2e45d3107549199251b504f128b8fc254b683c7d9c0841b86cd4c32cd45c9d3cbddc3f989bd965d61ef5a0dca9212431876c00a13f8398ff45f4c
+EBUILD megaglest-data-3.13.0-r1.ebuild 780 BLAKE2B dd72dd06a9d7ad2f1c740617cff4bc77164e247fc86c22c4c3b88efc4689cdca5a534a52bb4e8894abb609bfd5f904a9cbc682707bda6485e29eb8e9bf5de6f7 SHA512 ec2f2e60f7789f53b4a949386890cc93c0a899a4f7a82264cccc217507a43214e918d40e58c0855f33bf480f7dcd57b63a7a1788005265a1e65a8fd31b59d321
EBUILD megaglest-data-3.13.0.ebuild 735 BLAKE2B c673c37e617fdfcb580555102528cd93eb67fd9cfb82643da88137dcf8d6a1d8b74bdc766f92bfc0aca5ee817635d68dbb86b356ae06e67bb4e601bbaccab50c SHA512 8011dca05ea8cfcd2cf2d2f3fe897225919cdf0504c27ae2a9181f49374397c0b38d6f744fe5c5fcad68ce785e8680a53306829ad99ca4605497a34d231214d9
MISC metadata.xml 343 BLAKE2B 28d402d1670909a99503c02f9778a0686035f08273dfe5f03bc11f26cafefbf15bb2041ea20670e292877ae2a1983a685eb634c404786b59a721a6b11928ec66 SHA512 59ec858c8f0622fcd97211175a250f0e97bbbcc01cf1c2d9ed74e6717e1ac81589653f1edaf8edb38406753b380ba1ecdbbb0c90c085d8d39663d8635732f204
diff --git a/games-strategy/megaglest-data/files/megaglest-data-3.13.0-cmake4.patch b/games-strategy/megaglest-data/files/megaglest-data-3.13.0-cmake4.patch
new file mode 100644
index 000000000000..f5408771b9be
--- /dev/null
+++ b/games-strategy/megaglest-data/files/megaglest-data-3.13.0-cmake4.patch
@@ -0,0 +1,24 @@
+Fix build with CMake 4
+https://github.com/MegaGlest/megaglest-data/commit/df2ae0a5f6300a4a9d16efa024e177fbe7b6ff9a
+https://bugs.gentoo.org/951889
+From df2ae0a5f6300a4a9d16efa024e177fbe7b6ff9a Mon Sep 17 00:00:00 2001
+From: Jammyjamjamman <jdsherratt3@gmail.com>
+Date: Sat, 4 Mar 2023 21:25:45 +0000
+Subject: [PATCH] Bump minimum cmake
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 58e57263..1e860c4c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ ##################################################################################
+ # Game data
+-CMAKE_MINIMUM_REQUIRED( VERSION 2.8.2 )
++CMAKE_MINIMUM_REQUIRED( VERSION 3.10 )
+ PROJECT( MegaGlest )
+
+ OPTION(WANT_INSTALL_DATA "Install MegaGlest's data" ON)
diff --git a/games-strategy/megaglest-data/megaglest-data-3.13.0-r1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.13.0-r1.ebuild
new file mode 100644
index 000000000000..aa28f68ba941
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.13.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="https://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/${P}.tar.xz"
+S="${WORKDIR}/megaglest-${PV}"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+PATCHES=( "${FILESDIR}/${P}-cmake4.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEGAGLEST_APPDATA_INSTALL_PATH="${EPREFIX}"/usr/share/metainfo #709450
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( docs/{AUTHORS.data,CHANGELOG,README}.txt )
+ use doc && local HTML_DOCS=( docs/glest_factions )
+
+ cmake_src_install
+}