summaryrefslogtreecommitdiff
path: root/games-strategy
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/Manifest.gzbin7588 -> 7583 bytes
-rw-r--r--games-strategy/freecol/Manifest4
-rw-r--r--games-strategy/freecol/freecol-1.2.0.ebuild75
-rw-r--r--games-strategy/freecol/metadata.xml2
-rw-r--r--games-strategy/naev/Manifest2
-rw-r--r--games-strategy/naev/naev-0.12.1.ebuild116
-rw-r--r--games-strategy/openra/Manifest2
-rw-r--r--games-strategy/openra/files/openra-20231010-handle-multilib.patch39
-rw-r--r--games-strategy/openra/openra-20231010-r2.ebuild214
-rw-r--r--games-strategy/warzone2100/Manifest3
-rw-r--r--games-strategy/warzone2100/files/warzone2100-4.5.5-gcc15-cstdint.patch10
-rw-r--r--games-strategy/warzone2100/warzone2100-4.5.5.ebuild130
12 files changed, 478 insertions, 119 deletions
diff --git a/games-strategy/Manifest.gz b/games-strategy/Manifest.gz
index 5c0447343c83..15a2c1a0fcc7 100644
--- a/games-strategy/Manifest.gz
+++ b/games-strategy/Manifest.gz
Binary files differ
diff --git a/games-strategy/freecol/Manifest b/games-strategy/freecol/Manifest
index 1b8604541962..55566bff638f 100644
--- a/games-strategy/freecol/Manifest
+++ b/games-strategy/freecol/Manifest
@@ -1,3 +1,5 @@
DIST freecol-1.0.0-src.zip 159875314 BLAKE2B 6153be9553ded4c2a1f9635d67e48165d07b5d1634f26a44d2f01195e1610d6cb525ffa60368f3225cdf62ffd7751242942fd86b5735455e7396deca68d8350d SHA512 68b313b42fc38e6ea95a4a04ca5af534c4487709fb036018d6d09f6de3455325031ad1fd0ae4c6415cbbeebd3f181e598a2602ad7be6cca9150ad9523b8bb3c2
+DIST freecol-1.2.0-src.zip 231798930 BLAKE2B 2c53498843a4d25356269dd3a6ab4929ce77ad9346ad3a55c98a3b8afca3bda99278d01fdb20d65036499059b1b18c69e4a5895818cd5d2184642683786ad5f6 SHA512 197a4277afe99928cb220cee6d9d113ef4e7b4a68430b62423f3da5afc146ce2e644e3ada7d788e60288caf2bd49e4e68fa95059762813321a4e8f23012b8010
EBUILD freecol-1.0.0-r1.ebuild 1656 BLAKE2B 334ca3c74b60dfb5d580c013f2db41d9d1ed1c77aa0d11900213c4fcf38803e1f14d615ac91febbca38fac734d604e9bf2bee9faa8761ee7b6d7f527cef0a471 SHA512 5c55c9b5d8134dd0492448a8fc73c2048948d1b87500879673773809686620855960761019371c328c169fa3f173ba4872853caed589fae6b520dbc133bf35e7
-MISC metadata.xml 445 BLAKE2B ce65886f52a3797fbe4b09ad23da333563076d76e9d4bc88a10dfbe6740c9e3d354f0765022f2e59eeb0e94aa21d237c455150ff4e0a4bff5fa761d9e51e3fd3 SHA512 0ed4f4f69b731aa67d73f222f69bc6e4bbafb2c56b00ff3e42a1f03646d6e48e141e59179fefb6e8b9ec2c4ec06b3983c38c4eb14d7ecd47f26e28a9909ffbdc
+EBUILD freecol-1.2.0.ebuild 1812 BLAKE2B 6e6fb2ed4feb44ed9414c7f1d606f27f16c7b172d78ab2206516f8127eb5edbaec3f6e5fd7763a194ff1d4689b3d45ffcc8967f0e4851ae58f2e87d7fb743f8b SHA512 95c209f516de6500b5047e41894b4331a654e81b6941d0c264427c53b97589c26a92fde9ba30f79e96ed58d08add063605a22a6d97f86fcc1323e65fbadcf4a7
+MISC metadata.xml 591 BLAKE2B e941368f86eed35320225b6c14f2c79a10875cd9279b23a40851de1997186b56451057eb1697c7b6c41c999c3f67de2e410514fd30d359c2f3499f8f7e40cd5d SHA512 445607a4a72b2b7500027e3aed44f289c963cc0f13945818867de7505b90f806029002140f185e23df6b6f2877f98aa752179d5cdab72ee55bedb238ad931991
diff --git a/games-strategy/freecol/freecol-1.2.0.ebuild b/games-strategy/freecol/freecol-1.2.0.ebuild
new file mode 100644
index 000000000000..82d5ae9b33db
--- /dev/null
+++ b/games-strategy/freecol/freecol-1.2.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit desktop java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Open source clone of the game Colonization"
+HOMEPAGE="https://www.freecol.org"
+# GH distfiles are over 3 times the size
+SRC_URI="https://downloads.sourceforge.net/project/freecol/${PN}/${P}/${P}-src.zip"
+S="${WORKDIR}/${PN}"
+
+LICENSE="CC-BY-SA-4.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CP_DEPEND="
+ dev-java/commons-cli:0
+ dev-java/cortado:0
+ dev-java/findbugs-annotations:0
+ dev-java/miglayout:5
+"
+DEPEND="
+ >=virtual/jdk-11:*
+ ${CP_DEPEND}
+"
+# error: variables in try-with-resources are not supported in -source 8
+RDEPEND="
+ >=virtual/jre-11:*
+ ${CP_DEPEND}
+"
+BDEPEND="app-arch/unzip"
+
+DOCS=( {CHANGELOG,README,SECURITY}.md )
+
+JAVA_JAR_FILENAME="FreeCol.jar"
+JAVA_RESOURCE_DIRS="resources"
+JAVA_SRC_DIR="src"
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_RUN_ONLY="net.sf.freecol.AllTests"
+JAVA_TEST_SRC_DIR="test/src"
+
+src_prepare() {
+ java-pkg-2_src_prepare
+ java-pkg_clean
+ mkdir -p "${JAVA_RESOURCE_DIRS}/META-INF" || die
+ cp build/splash.jpg "${JAVA_RESOURCE_DIRS}" || die # install splash screen
+ grep Main-Class src/MANIFEST.MF \
+ > "${JAVA_RESOURCE_DIRS}/META-INF/MANIFEST.MF" || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ local datadir=/usr/share/${PN}
+
+ # launcher of java-pkg-simple.eclass seems not to support --pwd
+ java-pkg_dolauncher ${PN} \
+ --pwd ${datadir} \
+ --main net.sf.freecol.FreeCol \
+ --java_args -Xmx2000M
+
+ insinto ${datadir}
+ doins -r data schema
+
+ doicon -s 32 packaging/common/${PN}.xpm
+ doicon -s 64 packaging/common/${PN}_64x64.xpm
+ newicon packaging/common/${PN}_90x90.xpm ${PN}.xpm
+
+ domenu packaging/common/${PN}.desktop
+}
diff --git a/games-strategy/freecol/metadata.xml b/games-strategy/freecol/metadata.xml
index ef642e3b3ea4..6ecfda1abc39 100644
--- a/games-strategy/freecol/metadata.xml
+++ b/games-strategy/freecol/metadata.xml
@@ -7,7 +7,9 @@
</maintainer>
<upstream>
<bugs-to>https://sourceforge.net/p/freecol/bugs/</bugs-to>
+ <changelog>https://sourceforge.net/p/freecol/git/ci/master/tree/CHANGELOG.md</changelog>
<doc>https://github.com/FreeCol/freecol/wiki</doc>
<remote-id type="sourceforge">freecol</remote-id>
+ <remote-id type="github">FreeCol/freecol</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-strategy/naev/Manifest b/games-strategy/naev/Manifest
index 054fc015c52e..771b93406c00 100644
--- a/games-strategy/naev/Manifest
+++ b/games-strategy/naev/Manifest
@@ -1,5 +1,3 @@
-DIST naev-0.12.1-source.tar.xz 463479836 BLAKE2B 5643e66d88e078d242642d0010e2f001a29d248633f624364196749aa59ec32787bf23e1960784b9e81acf1c4309e7f0987f5afe2a2c12c257208822bc1cd174 SHA512 d6bbe25d930723fec1786f7160ef72091d1480714bdec2032a8d194aec281ca352eaab0a4b8af538b79068be972cf28fc81d681ff5659733cdc2044ad250a9df
DIST naev-0.12.2-source.tar.xz 465301164 BLAKE2B 1a9af216a66677dbbdcf381eff9b638df47610e7a7e1ffe881234805594b40ebdf76adf413458b936a487a807f7238e1e45f2479fd8ae1fcca352cc584d48493 SHA512 898a1c4e820f1bad5b3abfdbf255d6a54363462e3eaf6bbcffd9f806398094100fa3776fb4bcbc8510b2a159cf73e49d9909213e671f979cbf7b4983e2f43b3e
-EBUILD naev-0.12.1.ebuild 2534 BLAKE2B c721a88376fd11d6e60b5b32ad5fd3a4ec46361f04895fa6c98f1159825b72906643665d598f1bfa479176c8035a8714f29dd350f71ff83c59e049dee94445c9 SHA512 781fc6ea5804c67e7488c67f87c1f6facf968be1a6cfbd49b5467bd76dd06f23ce2ae08a747b8864b1f3dfffb42eb10f0433757e360922556418c0207a66c27b
EBUILD naev-0.12.2.ebuild 2355 BLAKE2B e6300088539fd74a59fab76e08655f277d621b6a7f432d718a756a6b7b9a5ae4b76056b17f62edfb4b4996e41265b00f1fcc6601af24f55aa993376583b3d4ef SHA512 a87edbaaeff3f616834277c5cac79b6415810335224aeb3156d17cb24527f8c7cfbdcf584dfac726d438aaa4b42cf2ffe02bf9ad222d31812de18489b225122f
MISC metadata.xml 328 BLAKE2B 2c831943c7eee723e5c707906bcec96e97abd71e5d6fc3256010cca9626aebe95ecd7dca316a9567fe41186f0a656a434d774f83f088f414a95b3aba425c23b9 SHA512 426ac4b34b6cb45db05f5a7768a15947f67f5e90cda1bafa817320988aeb96ade18d774b2aa5e92d12c1fd1fd7a4964ac1bbdacbca6655325ccccc6a9405dfa4
diff --git a/games-strategy/naev/naev-0.12.1.ebuild b/games-strategy/naev/naev-0.12.1.ebuild
deleted file mode 100644
index eb81049661fb..000000000000
--- a/games-strategy/naev/naev-0.12.1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( luajit )
-PYTHON_COMPAT=( python3_{10..13} )
-inherit lua-single meson python-any-r1 virtualx xdg
-
-DESCRIPTION="2D space trading and combat game, in a similar vein to Escape Velocity"
-HOMEPAGE="https://naev.org/"
-SRC_URI="https://github.com/naev/naev/releases/download/v${PV}/${P}-source.tar.xz"
-
-LICENSE="
- GPL-3+
- Apache-2.0 BSD BSD-2 CC-BY-2.0 CC-BY-3.0 CC-BY-4.0 CC-BY-SA-3.0
- CC-BY-SA-4.0 CC0-1.0 GPL-2+ MIT OFL-1.1 public-domain
-"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-# tests are very basic, equivalent of just starting the game and checking if
-# can see the main menu -- but this breaks easily with software rendering and
-# some Xorg/mesa versions, simpler to do manually than try to keep this working
-RESTRICT="test"
-
-# dlopen: libglvnd
-RDEPEND="
- ${LUA_DEPS}
- app-text/cmark:=
- dev-games/physfs
- dev-libs/libpcre2:=
- dev-libs/libunibreak:=
- dev-libs/libxml2
- dev-libs/libyaml
- dev-libs/nativefiledialog-extended
- media-libs/freetype:2
- media-libs/libglvnd
- media-libs/libsdl2[joystick,opengl,video]
- media-libs/libvorbis
- media-libs/openal
- media-libs/sdl2-image[png,webp]
- net-libs/enet:1.3=
- sci-libs/cholmod
- sci-libs/cxsparse
- sci-libs/openblas
- sci-libs/suitesparse
- sci-mathematics/glpk:=
- virtual/libintl
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-games/physfs[zip]
- media-libs/libsdl2[X]
- )
-"
-BDEPEND="
- $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
- sys-devel/gettext
- doc? (
- app-text/doxygen
- dev-lua/ldoc
- media-gfx/graphviz
- )
- test? (
- media-libs/mesa[llvm]
- x11-base/xorg-server[-minimal]
- )
-"
-
-python_check_deps() {
- python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- lua-single_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # don't probe OpenGL for tests (avoids sandbox violations, bug #829369)
- sed -i "/subdir('glcheck')/d" test/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- # *can* do lua5-1 but upstream uses+test luajit most (bug #946881)
- -Dluajit=enabled
- $(meson_feature doc docs_c)
- $(meson_feature doc docs_lua)
- )
-
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}
-
-src_install() {
- local DOCS=( CHANGELOG Readme.md )
- meson_src_install
-
- if use doc; then
- dodir /usr/share/doc/${PF}/html
- mv -- "${ED}"/usr/{doc/naev/{c,lua},share/doc/${PF}/html} || die
- rm -r -- "${ED}"/usr/doc || die
- fi
-
- rm -r -- "${ED}"/usr/share/doc/naev || die
-}
diff --git a/games-strategy/openra/Manifest b/games-strategy/openra/Manifest
index 8a45a65c309c..0ab9ecd1f378 100644
--- a/games-strategy/openra/Manifest
+++ b/games-strategy/openra/Manifest
@@ -1,4 +1,5 @@
AUX openra-20231010-configure-system-libraries.patch 316 BLAKE2B 4251fdc26ef4e1f7bb3b01af3f8fe62dd1f5c72b1a2520c62cb8ed98af294342d07b4bca1b0ac2245a1483cac4dc3fa12ac66dd29a7271d9bd22e315ce429151 SHA512 218e9adb55247b9dc77eb8163a930560b08e72475b38606a81a49608115f8ea88ffe611359bec7cd745cf5bcb0443942b6f4e548528da52f62449b3f6f1d1d68
+AUX openra-20231010-handle-multilib.patch 1333 BLAKE2B a03b91374644e0bef911d8c2726861969b10701c0bc1daa935169b2c82ee97d76e04c9e14ff4e5aef533259046b3c6d7c7217fc3a604bd91d0ed091f815738b9 SHA512 86f28a0a023a50a7fba4d05b1c02e9db09dd44320ed95be82c39d02fe4017480bf1990f2a65b2a47363ed72fe979bf239f287dd269b4901a89ce25c4846d491a
AUX openra-20231010-makefile.patch 1323 BLAKE2B f444bfae32abd76dc72b05552000498aa7d532acfbce0acfbce7d034b695c937c0577bb1b22a39305ecc1cc66cd4b0232b609e6803cbc78c9929b3c6cd179ff1 SHA512 45edabb76284adaf05fbf2ceb0f0981bc70d3a7d032a53d9b75577a0693ca1278654447961806af72b55ab73f1350f95a6f6c86a6f17bab67577ba05956671c3
AUX openra-20231010-packaging-functions.patch 410 BLAKE2B 7beb9f6a1ad32a927095f72f0870dd1773f3413fb0195592b6d7a672d8ea31397945a5838eda36cf0cc33fe4968003962f42abb1597f1b29f496617dbdae941f SHA512 aff0e872f173ff8a68ab1b0efcc1824c141c5cdcce3507513497e06033c463c41315a54100f5d265f823d99cb3a7dabdf490fb9328212a8f2219c6daf8fd5dc2
AUX openra-system-geoip.patch 1660 BLAKE2B bd81875d781157702f99794fe1e4e9cc904edec18566b2a2c8a90b81fe6d684768bf9ef76a7f7864474b6cbdcd10ec28fbbd053e007f71e6af53de7bc6cab6b9 SHA512 58acbba9996e1176fb21c2c9d3496f07e6cf920985cbfa83dc7bdab1b9698c678fe9ce78d16c1a0bf9982e21a03df48bccf5332ad2114b2c2181146b71c9de30
@@ -125,4 +126,5 @@ DIST system.valuetuple.4.5.0.nupkg 204904 BLAKE2B effebc14eba236b1b5c4dbbab54478
DIST taglibsharp.2.3.0.nupkg 1378355 BLAKE2B 219f809b22bfeab2b2a16759f77c04912e4af8565b6fb0e55024a3d4cc6c80c9f0f3c61d9f0aa9771dbbe0feb17415142243f8564e81b548d067b1be44a15996 SHA512 9be37f6431f6ead36babe78dc6527340d7b4b0fe444736aaeae5aef3651191d4e0421d9d671106aea544888695d7841000fb12f8a44aab1b5fe93fb7c90d983f
EBUILD openra-20190314-r100.ebuild 5057 BLAKE2B 40feb35b396cbf309a36d9cf290a31ec7e3442bebdfc564c1734f9d755bfd981ce0d582d07b19acb91622de5e472e1a0c03c80f2ee056488490d7314ee3ff4ad SHA512 0e81fd0da69a10c4f769acc35d56531184863592a877812666b1428fcffb6bd25f04964c82d26ec3f12fffc7ac83591180a8ce026ccde97760f4ee04be651a5a
EBUILD openra-20231010-r1.ebuild 6343 BLAKE2B b7cb78a603d46e14deaa9fd4c1ae5ab14ce965813e7f32d7da60799c01314e64f6c92a467bed4c9eb48d85696754179c891aac14abd9ab1822e11ac875938d5b SHA512 de75522f163ae894730b833379c10b114e7f9a1f85adc57a7aa8e3ed94ccde394fb3582626dafe9d5fa0b23eaeff30754a7035b4f11b9fff151a28683eea34ec
+EBUILD openra-20231010-r2.ebuild 6395 BLAKE2B 4419b75035a4eef6b1360f86e95b097b6331572bd053a2fc41ec153f90b045f07bcae7aacdaeed6320c0b7772e063cc2ba4ae17d0ea3c035d26b3835ad298ee6 SHA512 8c86162c2c2fc7d686a4a068b9edc8e64b2a4145bf70d8212d39db1ea91d37e1e5bcc3b99a83a0e57ce0be6ea7d9d69baa26d6d08270c237572d64596b3cdceb
MISC metadata.xml 624 BLAKE2B cbd1c42f0f9d04c1c467d55f3a16e476c7071db4458f8b0df557e2d631bcfc958d5ab4c178b2f0571e11ee1ca25b49c94f98623a1773926af06046618952deed SHA512 1ad70b919b74abfb8f03d0c22f3b842d97b37175f02184cc037fb7922fbfb62bccf690adf4e85d852959eaf191cb24e4f98af43850a6b2690cb37b62816c46ac
diff --git a/games-strategy/openra/files/openra-20231010-handle-multilib.patch b/games-strategy/openra/files/openra-20231010-handle-multilib.patch
new file mode 100644
index 000000000000..8faaedde9243
--- /dev/null
+++ b/games-strategy/openra/files/openra-20231010-handle-multilib.patch
@@ -0,0 +1,39 @@
+https://github.com/OpenRA/OpenRA/pull/21382
+https://github.com/OpenRA/OpenRA/issues/21353
+
+From 5ec6e5d5a45855e047d251864292524a9b7a4597 Mon Sep 17 00:00:00 2001
+From: Jakub Vesely <jakub.vesely2@gmail.com>
+Date: Mon, 1 Apr 2024 15:03:00 +0200
+Subject: [PATCH] configure-system-libraries.sh: Skip 32bit libraries during
+ lookup on x64 Linux. #21353
+
+--- a/configure-system-libraries.sh
++++ b/configure-system-libraries.sh
+@@ -5,7 +5,6 @@
+ # This file must stay /bin/sh and POSIX compliant for macOS and BSD portability.
+ # Copy-paste the entire script into http://shellcheck.net to check.
+ ####
+-
+ set -o errexit || exit $?
+
+ patch_config()
+@@ -37,11 +36,18 @@ patch_config()
+ if [ -L "bin/${REPLACE}" ]; then
+ return 0
+ fi
+-
++ KERNEL="$(uname -s)"
++ ARCH="$(arch)"
+ printf "Searching for %s... " "${LABEL}"
+ for DIR in ${SEARCHDIRS} ; do
+ for LIB in ${SEARCH}; do
+ if [ -f "${DIR}/${LIB}" ]; then
++ # x86-64 Linux might have 32-bit libraries present, link against the 64 bit libraries since there is no 32-bit Linux release of dotnet
++ if [ "${KERNEL}" = "Linux" ] && [ "${ARCH}" = "x86_64" ]; then
++ if [ "$(LANG=C file -L -b "${DIR}/${LIB}" | cut -d" " -f2)" != "64-bit" ]; then
++ continue
++ fi
++ fi
+ echo "${LIB}"
+ ln -s "${DIR}/${LIB}" "bin/${REPLACE}"
+ return 0
diff --git a/games-strategy/openra/openra-20231010-r2.ebuild b/games-strategy/openra/openra-20231010-r2.ebuild
new file mode 100644
index 000000000000..77c5f66e3032
--- /dev/null
+++ b/games-strategy/openra/openra-20231010-r2.ebuild
@@ -0,0 +1,214 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 )
+
+DOTNET_PKG_COMPAT=6.0
+NUGETS="
+discordrichpresence@1.1.3.18
+linguini.bundle@0.5.0
+linguini.shared@0.5.0
+linguini.syntax@0.5.0
+microsoft.extensions.dependencymodel@6.0.0
+microsoft.netcore.platforms@1.1.0
+microsoft.netcore.platforms@1.1.1
+microsoft.netcore.platforms@5.0.0
+microsoft.netcore.targets@1.1.0
+microsoft.win32.primitives@4.3.0
+microsoft.win32.registry@5.0.0
+mono.nat@3.0.4
+mp3sharp@1.0.5
+newtonsoft.json@13.0.1
+nuget.commandline@4.4.1
+nvorbis@0.10.5
+openra-eluant@1.0.22
+openra-freetype6@1.0.11
+openra-fuzzylogiclibrary@1.0.1
+openra-openal-cs@1.0.22
+openra-sdl2-cs@1.0.40
+pfim@0.11.2
+rix0rrr.beaconlib@1.0.2
+runtime.any.system.collections@4.3.0
+runtime.any.system.diagnostics.tracing@4.3.0
+runtime.any.system.globalization.calendars@4.3.0
+runtime.any.system.globalization@4.3.0
+runtime.any.system.io@4.3.0
+runtime.any.system.reflection.primitives@4.3.0
+runtime.any.system.reflection@4.3.0
+runtime.any.system.resources.resourcemanager@4.3.0
+runtime.any.system.runtime.handles@4.3.0
+runtime.any.system.runtime.interopservices@4.3.0
+runtime.any.system.runtime@4.3.0
+runtime.any.system.text.encoding.extensions@4.3.0
+runtime.any.system.text.encoding@4.3.0
+runtime.any.system.threading.tasks@4.3.0
+runtime.debian.8-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.fedora.23-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.fedora.24-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.native.system.net.http@4.3.0
+runtime.native.system.security.cryptography.apple@4.3.0
+runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.native.system@4.3.0
+runtime.opensuse.13.2-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.opensuse.42.1-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.osx.10.10-x64.runtime.native.system.security.cryptography.apple@4.3.0
+runtime.osx.10.10-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.rhel.7-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.ubuntu.14.04-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.ubuntu.16.04-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.ubuntu.16.10-x64.runtime.native.system.security.cryptography.openssl@4.3.2
+runtime.unix.microsoft.win32.primitives@4.3.0
+runtime.unix.system.diagnostics.debug@4.3.0
+runtime.unix.system.io.filesystem@4.3.0
+runtime.unix.system.net.primitives@4.3.0
+runtime.unix.system.private.uri@4.3.0
+runtime.unix.system.runtime.extensions@4.3.0
+sharpziplib@1.4.2
+stylecop.analyzers.unstable@1.2.0.435
+stylecop.analyzers@1.2.0-beta.435
+system.buffers@4.3.0
+system.buffers@4.5.1
+system.collections.concurrent@4.3.0
+system.collections@4.3.0
+system.diagnostics.debug@4.3.0
+system.diagnostics.diagnosticsource@4.3.0
+system.diagnostics.tracing@4.3.0
+system.globalization.calendars@4.3.0
+system.globalization.extensions@4.3.0
+system.globalization@4.3.0
+system.io.filesystem.primitives@4.3.0
+system.io.filesystem@4.3.0
+system.io@4.3.0
+system.linq@4.3.0
+system.memory@4.5.3
+system.memory@4.5.4
+system.net.http@4.3.4
+system.net.primitives@4.3.0
+system.private.uri@4.3.0
+system.reflection.primitives@4.3.0
+system.reflection@4.3.0
+system.resources.resourcemanager@4.3.0
+system.runtime.compilerservices.unsafe@6.0.0
+system.runtime.extensions@4.3.0
+system.runtime.handles@4.3.0
+system.runtime.interopservices@4.3.0
+system.runtime.loader@4.3.0
+system.runtime.numerics@4.3.0
+system.runtime@4.3.0
+system.security.accesscontrol@5.0.0
+system.security.cryptography.algorithms@4.3.0
+system.security.cryptography.cng@4.3.0
+system.security.cryptography.csp@4.3.0
+system.security.cryptography.encoding@4.3.0
+system.security.cryptography.openssl@4.3.0
+system.security.cryptography.primitives@4.3.0
+system.security.cryptography.x509certificates@4.3.0
+system.security.principal.windows@5.0.0
+system.text.encoding.extensions@4.3.0
+system.text.encoding@4.3.0
+system.text.encodings.web@6.0.0
+system.text.json@6.0.0
+system.threading.channels@6.0.0
+system.threading.tasks@4.3.0
+system.threading@4.3.0
+system.valuetuple@4.5.0
+taglibsharp@2.3.0
+"
+
+inherit check-reqs dotnet-pkg lua-single xdg
+
+DESCRIPTION="A free RTS engine supporting games like Command & Conquer, Red Alert and Dune2k"
+HOMEPAGE="https://www.openra.net/
+ https://github.com/OpenRA/OpenRA/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/OpenRA/OpenRA.git"
+else
+ SRC_URI="https://github.com/OpenRA/OpenRA/archive/release-${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/OpenRA-release-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+
+# Engine is GPL-3, dependent DLLs are mixed.
+LICENSE="GPL-3 Apache-2.0 BSD GPL-2 MIT"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-misc/ca-certificates
+ media-libs/freetype:2
+ media-libs/libsdl2[opengl,video]
+ media-libs/openal
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+CHECKREQS_DISK_BUILD="2G"
+PATCHES=(
+ "${FILESDIR}/${PN}-20231010-configure-system-libraries.patch"
+ "${FILESDIR}/${PN}-20231010-makefile.patch"
+ "${FILESDIR}/${PN}-20231010-packaging-functions.patch"
+ "${FILESDIR}/${PN}-20231010-handle-multilib.patch"
+)
+
+DOCS=( AUTHORS CODE_OF_CONDUCT.md CONTRIBUTING.md README.md )
+
+pkg_setup() {
+ check-reqs_pkg_setup
+ dotnet-pkg_pkg_setup
+ lua-single_pkg_setup
+}
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_compile() {
+ emake VERSION="release-${PV}" version
+ emake RUNTIME=net6
+}
+
+src_install() {
+ local openra_home="/usr/lib/${PN}"
+
+ # We compiled to "bin", not standard "dotnet-pkg" path.
+ mkdir -p "${ED}/usr/share" || die
+ cp -r bin "${ED}/usr/share/${P}" || die
+
+ # This is used by "linux-shortcuts" (see below make-install).
+ dotnet-pkg-base_launcherinto "${openra_home}"
+ dotnet-pkg-base_dolauncher "/usr/share/${P}/OpenRA" OpenRA
+ dotnet-pkg-base_dolauncher "/usr/share/${P}/OpenRA.Server" OpenRA.Server
+
+ emake DESTDIR="${ED}" RUNTIME=net6 prefix=/usr bindir=/usr/bin \
+ install install-linux-shortcuts install-linux-appdata install-man
+
+ local -a assets=(
+ glsl
+ mods
+ AUTHORS
+ COPYING
+ VERSION
+ 'global mix database.dat'
+ )
+ local asset
+ for asset in "${assets[@]}" ; do
+ dosym -r "${openra_home}/${asset}" "/usr/share/${P}/${asset}"
+ done
+
+ einstalldocs
+}
diff --git a/games-strategy/warzone2100/Manifest b/games-strategy/warzone2100/Manifest
index 0feba659501b..33bb3dcfcf68 100644
--- a/games-strategy/warzone2100/Manifest
+++ b/games-strategy/warzone2100/Manifest
@@ -1,6 +1,9 @@
AUX warzone2100-4.1.3-no-compress-manpages.patch 2317 BLAKE2B 00d67b7df0898b1a6343b38ffb7e1655d3f16a94bffe94894f3cff5e25f1e7f426046beda9983eea963bac5fb2a7e49aca473b8b78d141ac00baa250710093c1 SHA512 48b8c3f651bf7d504da88a6351799cc9cd19bf84191f52e9ca5b0c5c60b52a81587c8a03fde5e3d8d19e7770dc7b17dd60b59d8441b47221a7cda5a8008f9558
AUX warzone2100-4.4.2-gcc15-cstdint.patch 697 BLAKE2B 33e86cb9c5240429ba3a49c5e838d61b77889321bc74f397b025926b2a706cdbf21eb96c78b1d1c41d4c98df2e82d240dd48048b3c2164c45fe52e3074c53e61 SHA512 49920e67e02502e19a5b607420f7c4dd34065475a2870e67f683a2be2e5dca915ba4f35dd61787dcaa408e840ff68a5095d41501bd60a615a5420e23b3212ae7
+AUX warzone2100-4.5.5-gcc15-cstdint.patch 291 BLAKE2B f0a8c414689f833885864dec9f0fda5eb88928a24964e59dfc524a1642d28e2a8b345f774e6e0d2b43adc3d064c5344adc0f11d2300ee14d4983a0f4e6889316 SHA512 a2c91911ffd5d8a59d26316f94ecc395459bd3161876db2acecee5992310d13b39f857ee9cc96ed05aba9d9dfe1a42a8636fe72afcb8076d4bfbdb2f350c3410
DIST warzone2100-4.4.2.tar.xz 490182768 BLAKE2B 4b8f6825072c8dd29e1d4699b21123ff015e87da9b4f5043e40398ec5ec41ba12d414bbb01dd616a9e7f74f45407341e87a071ef38eb7c191e3845016f8df330 SHA512 8edfae77853826fda4bafafc513d9c6d999861fc4a7f0cf22318df7ebf9df3d7f98c3859eec8e8eeb02f4243b7e2e152c8d46881f4f8d414787ef0d0735ea4e6
+DIST warzone2100-4.5.5.tar.xz 507815568 BLAKE2B cc4ff66e2df7666ebb834ead839e2ac2345f3e105232c53d0ec72be375ae01530ff0532368549b196a1a8cbbf9b9903ab5467b7e30248d618bf6fc6e3030d8b0 SHA512 b153306ea8a55334a37580c2862579f6b6a283ba3c082901fcb97fe4da3a6ae4b7bc9bd7c1fa33f39a3b5113876080b90422174f376a7ed148a18f21f57ee8b3
DIST warzone2100-videos-2.2.wz 571937134 BLAKE2B 60b70a71bd920e2d72ded5d519b17db2f3db4b0289edadeb58059a21aba7038b95219dc44cb807754461d1a9bdca60f0d7698be68622b8bd64a55efa949622d3 SHA512 ca1a1af51296afdaca137114821508c5783f077090e665eae0f6df895855f57c43f84434706309e819417f5f35d1c649bd14e96dc9fbbb1252d30a4f9a223cf6
EBUILD warzone2100-4.4.2.ebuild 3018 BLAKE2B 34c18a3ca337352051e0dc218fe29437f1e360c982c23ec216d504f24e2fac762de27b67089c4576612373adba1a97f3d71b82bf96ce9a453a4bdedbf3f1ca9f SHA512 2c50188fa41760320ffb41877d3c10ef2531378af831c085a778c5c006898e9bd1d67bceb327eae64f199ea86162cce620641aaa2048dc717b6f5bb3bac05547
+EBUILD warzone2100-4.5.5.ebuild 3045 BLAKE2B 4a5c23a5567d346449100e2b7eb48a77dfbb34c1f71dc0201dcaa5e5b18804335597dfe69360783cd4a34a45a243b9e120f28e858e3f3c5d66eda13c5346865d SHA512 fe0da935f87422d18c64cf4098be761f6200a5c5493c133a928f8a74a772fea8306a6430b3b91533d3643ccd25d9f6af0b88f3303a7d89539162c8e42f021d62
MISC metadata.xml 761 BLAKE2B b936989bcdaef01522f294635531f699a2db868a80fd696051a60a10c70fb1f24cb721a34064d222938333f2fa956bb07463ce60a5490c0cadfca2b9c69e987f SHA512 5e422b7b539f95705be9ef4cede8b3029e9bfc38e9fdd0002712432671956d946cb893a069839bad88a07ee4fc33bc6fa7e1042b1efdc8ea55823165fc77cb54
diff --git a/games-strategy/warzone2100/files/warzone2100-4.5.5-gcc15-cstdint.patch b/games-strategy/warzone2100/files/warzone2100-4.5.5-gcc15-cstdint.patch
new file mode 100644
index 000000000000..e3af62d1ffcd
--- /dev/null
+++ b/games-strategy/warzone2100/files/warzone2100-4.5.5-gcc15-cstdint.patch
@@ -0,0 +1,10 @@
+--- a/3rdparty/SQLiteCpp/include/SQLiteCpp/Statement.h
++++ b/3rdparty/SQLiteCpp/include/SQLiteCpp/Statement.h
+@@ -14,6 +14,7 @@
+ #include <SQLiteCpp/Exception.h>
+ #include <SQLiteCpp/Utils.h> // SQLITECPP_PURE_FUNC
+
++#include <cstdint>
+ #include <string>
+ #include <map>
+ #include <memory>
diff --git a/games-strategy/warzone2100/warzone2100-4.5.5.ebuild b/games-strategy/warzone2100/warzone2100-4.5.5.ebuild
new file mode 100644
index 000000000000..58670ad3ae60
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-4.5.5.ebuild
@@ -0,0 +1,130 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="ar_SA bg_BG ca_ES cs da de el en_GB eo es et_EE fa_IR fi fr fy ga he_IL hr hu id it ja_JP ko la lt my_MM nb nl pl pt pt_BR ro ru sk sl tr tt_RU uk_UA zh_CN zh_TW"
+inherit cmake flag-o-matic plocale xdg
+
+MY_PV=$(ver_cut 1-2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="https://wz2100.net/"
+SRC_URI="
+ https://downloads.sourceforge.net/warzone2100/releases/${PV}/${PN}_src.tar.xz -> ${P}.tar.xz
+ videos? ( https://downloads.sourceforge.net/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain vulkan? ( GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# Upstream requested debug support
+IUSE="debug discord nls videos vulkan"
+
+COMMON_DEPEND="
+ dev-libs/fribidi
+ >=dev-games/physfs-2[zip]
+ dev-db/sqlite:3
+ >=dev-libs/libsodium-1.0.14:=
+ media-libs/freetype:2
+ media-libs/harfbuzz:=
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libsdl2[opengl,video,X]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/opus
+ media-libs/opusfile
+ net-libs/miniupnpc:=
+ net-misc/curl
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ vulkan? ( media-libs/libsdl2:=[vulkan] )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ media-libs/fontconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-fonts/dejavu
+"
+BDEPEND="
+ app-arch/zip
+ app-text/asciidoc
+ games-util/basis_universal
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+HTML_DOCS=( doc/quickstartguide.html doc/docbook-xsl.css doc/ScriptingManual.htm )
+DOCS=( README.md doc/images doc/Scripting.md doc/js-globals.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.3-no-compress-manpages.patch
+ "${FILESDIR}"/${PN}-4.5.5-gcc15-cstdint.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.xz
+}
+
+src_prepare() {
+ sed -i -e 's/#top_builddir/top_builddir/' po/Makevars || die
+
+ # Delete translations we're not using
+ cleanup_po() {
+ local locale=${1}
+ einfo "Cleaning up disabled locale: ${locale}"
+ rm po/${locale}.po || die
+ }
+
+ plocale_for_each_disabled_locale cleanup_po
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # ODR violations (bison, yy_*, bug #859268)
+ filter-lto
+
+ # TODO: unbundle dev-cpp/nlohmann_json
+ # TODO: unbundle dev-libs/libfmt
+ # TODO: unbundle SQLiteCpp
+ # TODO: unbundle dev-libs/inih
+ local mycmakeargs=(
+ -DWZ_DISTRIBUTOR="Gentoo Linux"
+ -DWZ_ENABLE_WARNINGS_AS_ERRORS=OFF
+ -DWZ_ENABLE_BACKEND_VULKAN=$(usex vulkan)
+ -DBUILD_SHARED_LIBS=OFF
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_DISCORD=$(usex discord)
+
+ -DFMT_INSTALL=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ asciidoc -b html5 doc/quickstartguide.asciidoc || die
+}
+
+src_install() {
+ cmake_src_install
+
+ # We cover licencing within the ebuild itself
+ rm "${ED}"/usr/share/doc/${PF}/COPYING* \
+ "${ED}"/usr/share/doc/${PF}/copyright || die
+
+ if use videos ; then
+ insinto /usr/share/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
+ fi
+}