summaryrefslogtreecommitdiff
path: root/games-strategy/widelands/widelands-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/widelands/widelands-9999.ebuild')
-rw-r--r--games-strategy/widelands/widelands-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/games-strategy/widelands/widelands-9999.ebuild b/games-strategy/widelands/widelands-9999.ebuild
index 694f1e6b01d3..a573f92451d1 100644
--- a/games-strategy/widelands/widelands-9999.ebuild
+++ b/games-strategy/widelands/widelands-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -32,13 +32,16 @@ RDEPEND="
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-ttf
sys-libs/zlib:=[minizip]
- virtual/libintl"
+ virtual/libintl
+"
DEPEND="
${RDEPEND}
- dev-cpp/asio"
+ dev-cpp/asio
+"
BDEPEND="
${PYTHON_DEPS}
- sys-devel/gettext"
+ sys-devel/gettext
+"
src_configure() {
CMAKE_BUILD_TYPE=Release # disables -Werror