summaryrefslogtreecommitdiff
path: root/games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild')
-rw-r--r--games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild117
1 files changed, 0 insertions, 117 deletions
diff --git a/games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild b/games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild
deleted file mode 100644
index 3e39b944a707..000000000000
--- a/games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PLOCALES="af_ZA bg_BG ca_ES cs da de el en_GB eo es et_EE fa_IR fi fr fy ga he_IL hr hu id_ID id it ko la lt nb nl pl pt_BR pt ro ru sk sl tr tt_RU uk_UA zh_CN zh_TW"
-inherit cmake desktop plocale xdg
-
-MY_PV=$(ver_cut 1-2)
-VIDEOS_PV=2.2
-VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
-DESCRIPTION="3D real-time strategy game"
-HOMEPAGE="https://wz2100.net/"
-SRC_URI="mirror://sourceforge/warzone2100/releases/${PV}/${PN}_src.tar.xz -> ${P}.tar.xz
- videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0 public-domain vulkan? ( GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Upstream requested debug support
-IUSE="debug discord nls videos vulkan"
-
-# TODO: unbundle miniupnpc and quesoglc, bug #477610
-# quesoglc-0.7.2 is buggy: http://developer.wz2100.net/ticket/2828
-CDEPEND="
- >=dev-games/physfs-2[zip]
- dev-db/sqlite
- >=dev-libs/libsodium-1.0.14:=
- dev-libs/openssl:0=
- media-libs/freetype:2
- media-libs/glew:=
- media-libs/harfbuzz:=
- media-libs/libogg
- media-libs/libpng:=
- media-libs/libsdl2[opengl,video,X]
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/openal
- net-misc/curl
- sys-libs/zlib
- nls? ( virtual/libintl )
- vulkan? ( media-libs/libsdl2:=[vulkan] )
-"
-DEPEND="
- ${CDEPEND}
- dev-libs/fribidi
- media-libs/fontconfig
-"
-RDEPEND="
- ${CDEPEND}
- media-fonts/dejavu
-"
-BDEPEND="
- app-arch/zip
- app-text/asciidoc
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-HTML_DOCS=( doc/quickstartguide.html doc/docbook-xsl.css doc/ScriptingManual.htm )
-DOCS=( README.md doc/images doc/Scripting.md doc/js-globals.md )
-
-src_unpack() {
- unpack ${P}.tar.xz
-}
-
-src_prepare() {
- default
-
- sed -i -e 's/#top_builddir/top_builddir/' po/Makevars || die
-
- # Delete translations we're not using
- cleanup_po() {
- local locale=${1}
- einfo "Cleaning up disabled locale: ${locale}"
- rm po/${locale}.po || die
- }
-
- plocale_for_each_disabled_locale cleanup_po
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWZ_DISTRIBUTOR="Gentoo Linux"
- -DWZ_ENABLE_WARNINGS_AS_ERRORS=OFF
- -DWZ_ENABLE_BACKEND_VULKAN=$(usex vulkan)
- -DBUILD_SHARED_LIBS=OFF
- -DENABLE_NLS=$(usex nls)
- -DENABLE_DISCORD=$(usex discord)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- asciidoc -b html5 doc/quickstartguide.asciidoc || die
-}
-
-src_install() {
- cmake_src_install
-
- rm "${ED}"/usr/bin/.portable || die
-
- # We cover licencing within the ebuild itself
- rm "${ED}"/usr/share/doc/${PF}/COPYING* \
- "${ED}"/usr/share/doc/${PF}/copyright || die
-
- if use videos ; then
- insinto /usr/share/${PN}
- newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
- fi
-}