summaryrefslogtreecommitdiff
path: root/games-strategy/s25rttr
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/s25rttr')
-rw-r--r--games-strategy/s25rttr/Manifest3
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch56
-rw-r--r--games-strategy/s25rttr/s25rttr-0.9.5.ebuild6
3 files changed, 61 insertions, 4 deletions
diff --git a/games-strategy/s25rttr/Manifest b/games-strategy/s25rttr/Manifest
index 0155e044e805..8f27c96aac11 100644
--- a/games-strategy/s25rttr/Manifest
+++ b/games-strategy/s25rttr/Manifest
@@ -1,5 +1,6 @@
AUX s25rttr-0.9.0_pre20200723-cmake_lua_version.patch 296 BLAKE2B cabdc87d6184e59f0896762f3d3434a137fed4fd1c2dae84d30dbee5d4903e68ba01c30b92d0d5290dec9b371807c317b462213a421cadd172b78b08407f66aa SHA512 074ac3e70fec0da6bd4a9602052989a8b6c26b5cfef669d6330d9177547bbeeeef2a4e6b9d83a9e9cbdf4ec33df7dcce50a862e3c9e533049ad8452df6073816
+AUX s25rttr-0.9.5-boost.patch 2155 BLAKE2B 75dd2cfb5cb4775c76033996fada2f7577f228855eca4469a3360941f337b6b05bccd65cb734e9ec02be4b7c84839570edab1480cfdb455eef5165edb4adb804 SHA512 baab52badfd10f3ff106c1303382ba320eb2ed655cdf564b8c1b1e1a21e5502258e3b770b855d4acd18e56b609e495b2e9ce1793743fd6a42d5bc69c81806091
AUX s25rttr-0.9.5-gcc-13.patch 1527 BLAKE2B 23399f2a2d0e350d990a122195a2fbb6ece1f010ad31c7da24c3b7a4356f7cadf793149e40748c98d958ef5a3d0e401e8caeacc4b8872f66e148688e8caca9c5 SHA512 6208a550524d3a3364718a5aaa7b69205c48903394635f03339173920c2481ecd014b4f5e847ba5390a060100c848f7ebd48bd038ea99f9e17a9b72508f10799
DIST s25client_src_v0.9.5.tar.gz 30305585 BLAKE2B 77857743b5a1693ed373cb048c40fed150a4bf3d59f1314ffbb268f3e03ba8db2f44c20962c390f3a8c5b5b443ee0465d5c7bf726998ddf0334a861304211db8 SHA512 4926653075c7ba01e1e4ca516c52ad1694b46557c40c418e2a1f18d0a8fac9d4b73c20adc5403365ad6ba643823ed23dff5296717b3e057c42b17f1c20feb802
-EBUILD s25rttr-0.9.5.ebuild 2675 BLAKE2B 962e67d0e88034b1968ced39f23c681f319439c9eb45470858766698c7653f7c6d9980dfd8e8b0448ddaab7a6528cfb1768beb901cdf0ff6ed7cfff2a661de15 SHA512 1309ccf2030e98b9bc8cc49ec895d2e7195c3cbdabb719615ed54a3206c29ac08130b83fbe00876f1a4deb371c52a3f16b91b8ff4bacdb4ec9f35c0417de1fda
+EBUILD s25rttr-0.9.5.ebuild 2713 BLAKE2B e96d000ae6b5a43233d71c4c667d80a6718fa86be07188876893b8b3198752d5c7ed1229e09dc99191402bfa4d4a671cfff9b43f84ca11e031dafce5fffc0d22 SHA512 594a0978fcf94c571e11dc8413a706d99b105cc40feddcc6683d20895d2ccdb577ccb190ddcda194a20de4956290ac3526bea3accaaff8cff2d15e44671734d4
MISC metadata.xml 348 BLAKE2B bc23c51bcd3458b4f39a6b42dd73f35060319cdae4563a4288ef2ae9dc9e2a85e8bc4b357dff37d70f20abf5d79a4a5c20fb1a8c2ab4c994dd3290ea18d49c34 SHA512 c145a48fb294eb11195885f0cd97095c7258d3286bf1cd926b5d40682aea1767c52a5a163283345fe12416659a9c7500de58993379b0ba3c743f18e172696c6f
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch b/games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch
new file mode 100644
index 000000000000..ace37abf9627
--- /dev/null
+++ b/games-strategy/s25rttr/files/s25rttr-0.9.5-boost.patch
@@ -0,0 +1,56 @@
+From d1c6739e93a788b7ea9da7915642b2c8d6ab0656 Mon Sep 17 00:00:00 2001
+From: Alexander Grund <alexander.grund@tu-dresden.de>
+Date: Fri, 3 Feb 2023 16:30:09 +0100
+Subject: [PATCH] Fix compatibility with Boost 1.74+
+
+This has turned into an error in Boost 1.81
+Fixes #1551
+---
+ libs/s25main/network/GameClient.cpp | 8 +++++++-
+ 3 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/libs/s25main/network/GameClient.cpp b/libs/s25main/network/GameClient.cpp
+index 84e351c08..0989d5877 100644
+--- a/libs/s25main/network/GameClient.cpp
++++ b/libs/s25main/network/GameClient.cpp
+@@ -119,7 +119,13 @@ bool GameClient::HostGame(const CreateServerInfo& csi, const boost::filesystem::
+ if(playedMapPath != map_path)
+ {
+ boost::system::error_code ignoredEc;
+- copy_file(map_path, playedMapPath, boost::filesystem::copy_option::overwrite_if_exists, ignoredEc);
++ constexpr auto overwrite_existing =
++#if BOOST_VERSION >= 107400
++ boost::filesystem::copy_options::overwrite_existing;
++#else
++ boost::filesystem::copy_option::overwrite_if_exists;
++#endif
++ copy_file(map_path, playedMapPath, overwrite_existing, ignoredEc);
+ }
+ return GAMESERVER.Start(csi, map_path, map_type, hostPw)
+ && Connect("localhost", hostPw, csi.type, csi.port, true, csi.ipv6);
+
+From 96978da4aba9280217a5b36731c303c35819220b Mon Sep 17 00:00:00 2001
+From: Alexander Grund <Flamefire@users.noreply.github.com>
+Date: Thu, 23 May 2024 19:35:14 +0200
+Subject: [PATCH] Fix Boost.Filesystem include
+
+The directory iterator seems to have move to a different include.
+Just include all of it.
+---
+ callbacks.cpp | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/external/s25edit/callbacks.cpp b/external/s25edit/callbacks.cpp
+index 52ec86d..095c1d6 100644
+--- a/external/s25edit/callbacks.cpp
++++ b/external/s25edit/callbacks.cpp
+@@ -18,8 +18,7 @@
+ #include "CSurface.h"
+ #include "globals.h"
+ #include "helpers/format.hpp"
+-#include <boost/filesystem/operations.hpp>
+-#include <boost/filesystem/path.hpp>
++#include <boost/filesystem.hpp>
+ #include <algorithm>
+
+ namespace bfs = boost::filesystem;
diff --git a/games-strategy/s25rttr/s25rttr-0.9.5.ebuild b/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
index 4986896fd623..1184da066c3a 100644
--- a/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,6 +11,7 @@ MY_PN="s25client"
DESCRIPTION="Open source remake of The Settlers II: Gold Edition (needs original data files)"
HOMEPAGE="https://www.siedler25.org/"
SRC_URI="https://github.com/Return-To-The-Roots/${MY_PN}/releases/download/v${PV}/${MY_PN}_src_v${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}_v${PV}"
LICENSE="GPL-2+ GPL-3 Boost-1.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
@@ -42,10 +43,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0_pre20200723-cmake_lua_version.patch
"${FILESDIR}"/${PN}-0.9.5-gcc-13.patch
+ "${FILESDIR}"/${PN}-0.9.5-boost.patch
)
-S="${WORKDIR}/${MY_PN}_v${PV}"
-
# Build type is checked but blank is valid.
CMAKE_BUILD_TYPE=