summaryrefslogtreecommitdiff
path: root/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild')
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild b/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
index 9a1f00300e1b..d3e8912a573b 100644
--- a/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
+++ b/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
@@ -2,31 +2,30 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit cmake
-MY_PN="megaglest"
DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
HOMEPAGE="https://www.megaglest.org/"
-SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/${P}.tar.xz"
+S="${WORKDIR}/megaglest-${PV}"
LICENSE="CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc"
-DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
src_configure() {
- # See bug https://bugs.gentoo.org/709450.
local mycmakeargs=(
- -DMEGAGLEST_APPDATA_INSTALL_PATH=/usr/metainfo
+ -DMEGAGLEST_APPDATA_INSTALL_PATH="${EPREFIX}"/usr/share/metainfo #709450
)
+
cmake_src_configure
}
src_install() {
- use doc && HTML_DOCS="docs/glest_factions/"
+ local DOCS=( docs/{AUTHORS.data,CHANGELOG,README}.txt )
+ use doc && local HTML_DOCS=( docs/glest_factions )
+
cmake_src_install
}