summaryrefslogtreecommitdiff
path: root/games-strategy/freeorion
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeorion')
-rw-r--r--games-strategy/freeorion/Manifest3
-rw-r--r--games-strategy/freeorion/files/freeorion-0.5.0.1-boost1.85.patch57
-rw-r--r--games-strategy/freeorion/freeorion-0.5.0.1-r1.ebuild (renamed from games-strategy/freeorion/freeorion-0.5.0.1.ebuild)8
3 files changed, 65 insertions, 3 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index 9c56cf034122..35e374e26db1 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1,3 +1,4 @@
+AUX freeorion-0.5.0.1-boost1.85.patch 2287 BLAKE2B 30ba9d71ca0f69c42dd0b795e46702d324dddba727cfc14a80d2ba011809c78b3ebb51a600945e0a50d27f8fe0fc054814a4403cca63ce81d02508425c4cfbc9 SHA512 83ebc9a50121df011436bf6dcfb641601e15e224055e44b076a64a73e3623b7a6407c146477bf63cc1f150a5629aece870010d25fbb1c537fcdcb64c2b192b74
DIST FreeOrion_v0.5.0.1_Source.tar.gz 152861158 BLAKE2B 6924d4916fcd3ac93e7498b5247957a6fb62b8523aa49114e9e11ef5e3b89374966551bc14192fa7928951728ce814fb86d89365beb97aa7c2bc84408bfcadd2 SHA512 dc267231329f0615f12887f22139d57a2611f378e17e8b0f26c00efdb77e73ef737ff875350f805d34a07ca4ce0595758e4f61168878477ebbd92d0149bcdc22
-EBUILD freeorion-0.5.0.1.ebuild 2822 BLAKE2B 57e06b2443f6c1f35217c1fe89982543ae81d4a75702f2f5cc918d18ca1e98fd3e88fc08c96f04109e264d1efc6fb4d9e31cb8513895d41819bedcca362f736e SHA512 17effb25e8d460a992935fb9dc27c427f1469676e7e209ef197bab3d6eb727059d31539f7b58ca81f49e87e945348fc5ecfeb54474be375e79891991d28c6d68
+EBUILD freeorion-0.5.0.1-r1.ebuild 2872 BLAKE2B bea166126374b52dfb17f25d01eebd0a93b872cc069f360b87a0af023872f3d61d7dd2be9ba577619777da6ede1b57ee5dff4d885ba72b6fdb6a394c0dc733fa SHA512 5326b4ea0de19a26884945ab00746745ee33eeb7364112bfec3e0032c3ec61e8ee558879317785d7259556f6807fe53ee690c2cad28ef6e1ddd0594797b3a140
MISC metadata.xml 757 BLAKE2B 64e1e5a856369650c9d41b75f7af091c5fde43ab2992911cc81d5e4ba12d13fea5e4e82ae960e75208979aea38eeeb07d4bfebdb1eb45c035796ed854090cbe6 SHA512 5e631e52b5dbabbb6ce1cde6e416c4ed228dbf4a1ddda7899e5565c9abd5b7080894866aef375ff66cef3facd06faadcaea2ccefd8fb34d6bb461bfd32879d6e
diff --git a/games-strategy/freeorion/files/freeorion-0.5.0.1-boost1.85.patch b/games-strategy/freeorion/files/freeorion-0.5.0.1-boost1.85.patch
new file mode 100644
index 000000000000..cb7f450ffc37
--- /dev/null
+++ b/games-strategy/freeorion/files/freeorion-0.5.0.1-boost1.85.patch
@@ -0,0 +1,57 @@
+https://bugs.gentoo.org/932780
+https://github.com/freeorion/freeorion/issues/4897
+
+Backport of: https://github.com/freeorion/freeorion/pull/4899/commits
+--- a/GG/src/dialogs/FileDlg.cpp
++++ b/GG/src/dialogs/FileDlg.cpp
+@@ -11,3 +11,3 @@
+ #include <boost/algorithm/string/predicate.hpp>
+-#include <boost/filesystem/operations.hpp>
++#include <boost/filesystem.hpp>
+ #include <boost/format.hpp>
+@@ -217,3 +217,3 @@
+ fs::path filename_path = fs::system_complete(fs::path(m_init_filename));
+- m_files_edit->SetText(filename_path.leaf().string());
++ m_files_edit->SetText(filename_path.filename().string());
+ }
+@@ -550,3 +550,3 @@
+ if ((s_working_dir.string() != s_working_dir.root_path().string() &&
+- !s_working_dir.branch_path().string().empty()) ||
++ !s_working_dir.parent_path().string().empty()) ||
+ Win32Paths())
+@@ -696,6 +696,6 @@
+ if (s_working_dir.string() != s_working_dir.root_path().string() &&
+- !s_working_dir.branch_path().string().empty())
++ !s_working_dir.parent_path().string().empty())
+ {
+ // move to new directory
+- SetWorkingDirectory(s_working_dir.branch_path());
++ SetWorkingDirectory(s_working_dir.parent_path());
+
+--- a/util/Directories.cpp
++++ b/util/Directories.cpp
+@@ -6,5 +6,4 @@
+ #include <boost/algorithm/string/trim.hpp>
+-#include <boost/filesystem/convenience.hpp>
+-#include <boost/filesystem/operations.hpp>
+ #include <boost/date_time/posix_time/posix_time.hpp>
++#include <boost/filesystem.hpp>
+
+@@ -268,3 +267,3 @@
+ fs::path binary_file = fs::system_complete(FilenameToPath(argv0));
+- bin_dir = binary_file.branch_path();
++ bin_dir = binary_file.parent_path();
+ } catch (const fs::filesystem_error &) {
+@@ -317,3 +316,3 @@
+ fs::path binary_file = fs::system_complete(fs::path(path_text));
+- bin_dir = binary_file.branch_path();
++ bin_dir = binary_file.parent_path();
+
+--- a/util/OptionsDB.cpp
++++ b/util/OptionsDB.cpp
+@@ -16,4 +16,3 @@
+ #include <boost/algorithm/string/predicate.hpp>
+-#include <boost/filesystem/fstream.hpp>
+-#include <boost/filesystem/operations.hpp>
++#include <boost/filesystem.hpp>
+ #include <boost/range/algorithm_ext/erase.hpp>
diff --git a/games-strategy/freeorion/freeorion-0.5.0.1.ebuild b/games-strategy/freeorion/freeorion-0.5.0.1-r1.ebuild
index 7f69517f40d8..60ff58559cb2 100644
--- a/games-strategy/freeorion/freeorion-0.5.0.1.ebuild
+++ b/games-strategy/freeorion/freeorion-0.5.0.1-r1.ebuild
@@ -18,10 +18,9 @@ IUSE="+client doc test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
-# bug #932780 wrt boost upper bound
DEPEND="
${PYTHON_DEPS}
- $(python_gen_cond_dep '<dev-libs/boost-1.85:=[${PYTHON_USEDEP},nls,python]')
+ $(python_gen_cond_dep 'dev-libs/boost:=[${PYTHON_USEDEP},nls,python]')
sys-libs/zlib:=
client? (
media-libs/freetype
@@ -50,6 +49,10 @@ BDEPEND="
test? ( $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]') )
"
+PATCHES=(
+ "${FILESDIR}"/${P}-boost1.85.patch
+)
+
freeorion_check-reqs() {
# cc1plus processes may suddenly use ~1.5GB all at once early on (2+GB
# if debug symbols) then far less for the rest, check minimal jobs*1.5
@@ -75,6 +78,7 @@ src_prepare() {
}
src_configure() {
+ append-flags -fno-strict-aliasing #932780
filter-lto # -Werror=odr issues
local mycmakeargs=(