summaryrefslogtreecommitdiff
path: root/games-strategy/colobot
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/colobot')
-rw-r--r--games-strategy/colobot/Manifest6
-rw-r--r--games-strategy/colobot/colobot-0.1.12.ebuild67
-rw-r--r--games-strategy/colobot/colobot-9999.ebuild47
-rw-r--r--games-strategy/colobot/metadata.xml5
4 files changed, 103 insertions, 22 deletions
diff --git a/games-strategy/colobot/Manifest b/games-strategy/colobot/Manifest
index 80e1c36cfe61..9977c75a3225 100644
--- a/games-strategy/colobot/Manifest
+++ b/games-strategy/colobot/Manifest
@@ -1,4 +1,6 @@
DIST colobot-0.1.11.tar.gz 1430595 BLAKE2B 6e4a23f17631031a6f502b045637949d99bfcf8aa723f11c406c8cdb9b201b9a2771de8b8c92829bc890848a19eb182bc30a45a51e6d281ce64370f6c7a0d8a5 SHA512 fe32bc56b6fae9435c74a73b694b7d2b93667e5d15b1c57a7558e492613f0a5d4cab72ff341ab4c921150137282cc71292a1e31eb1ed06c752de33c50120f20e
+DIST colobot-gold-0.1.12-alpha.tar.gz 1468594 BLAKE2B 2b470e8b074e4a973b751062dca2358396066d8816c2b1b5b44649b798610dccd73ab5fed4086f2aa8d4495f3de69dd8b72b45f97f23f66b18a50fc976bf25ef SHA512 63647a16b376db6544830f96e7d323c0f58003645bf636abd1cab0ffd47b39b0bef47191d584f5156b75324d75dfdfdcabe8b89be565087c37c367ca366f3cbe
EBUILD colobot-0.1.11.ebuild 1372 BLAKE2B b40e81306d7fc183e9d523db5d60cd19a88880e010584bc4ccb762734ad34fe7ffc1ff50660cdd80e38edca4edfb915c047d4da93caafb82d1fec0c5779879e3 SHA512 19012df06321273072c51cd9408c80f487f53e979c0eaf31edf1fab574d3a41d4a37582a05888f4486891ae057e5341905f28dd686a8e94552d9fb38062cd0cd
-EBUILD colobot-9999.ebuild 1372 BLAKE2B b40e81306d7fc183e9d523db5d60cd19a88880e010584bc4ccb762734ad34fe7ffc1ff50660cdd80e38edca4edfb915c047d4da93caafb82d1fec0c5779879e3 SHA512 19012df06321273072c51cd9408c80f487f53e979c0eaf31edf1fab574d3a41d4a37582a05888f4486891ae057e5341905f28dd686a8e94552d9fb38062cd0cd
-MISC metadata.xml 338 BLAKE2B 0db6b76296a10e4fa2333490fe61d2d33a81b417a848225f2f1f6c52b2008b5f52afe8bcf2b60d56ce7c6bc73b402604821513ca830be647a13e7d9e0ac1f926 SHA512 bc695a245c9da3a0e334e4e9a465d773098beaf2b01df5f29b9ff83c543c848c0256617d42e3e43e0f76be7204b8ac504cb5b3f34861b2dab4ed232756866c75
+EBUILD colobot-0.1.12.ebuild 1478 BLAKE2B a66d5c4aa584706868cfa8f76a368f6c614f48767a086946eafad83a44ae44d3c24a70650f4aa88971998495b70ff1122d02fded40193eda6f8fe07fb7de4080 SHA512 fcb8e33bccbf67cb835732630f1b84009202cce3a02dd7a497050f8fd91c3cb4ae54f62e3b24c62e1aa2687a4067aeced47cea1c7f5fe15a7707c451478bda83
+EBUILD colobot-9999.ebuild 1422 BLAKE2B 3c0d22a6df76aa3303567bff0b42c0e52aa765b0ec7e1dc6822125a949fcf94b89bc5957778e3aa2553a36c316105d96edcd9351629bb809b2a6187967ef1391 SHA512 791b6935cedfd32412d2fabf75cc388d7cc21bdd17262b713efbce5c1627e72fa78e152d305cc4b7aa59cdbed5b94f124b4a0e6cc7df6aa9081f3c2c9fa645de
+MISC metadata.xml 418 BLAKE2B b30194895d7f35dc6b2bf5ed2d6153ab03832eff44536e837058b4c5641760c55ea846a3ffe91027d8892ab7ccd4a36be688b89a5909c57ca57a18f8a610f022 SHA512 6ffc5220d200c722b0e7da2ee8734282ea0fabd7d319f8a21cd88da6743312c869f44bd3b14af7031ce970feb9b6c4349236db2a7aee69ea8041e3b000812e3c
diff --git a/games-strategy/colobot/colobot-0.1.12.ebuild b/games-strategy/colobot/colobot-0.1.12.ebuild
new file mode 100644
index 000000000000..1611ef4a1d61
--- /dev/null
+++ b/games-strategy/colobot/colobot-0.1.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg-utils
+
+DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
+HOMEPAGE="https://colobot.info/"
+SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="devbuild doc +openal test tools"
+RESTRICT="!test? ( test )"
+
+# perl for pod2man
+BDEPEND="
+ app-text/po4a
+ dev-lang/perl
+ sys-devel/gettext"
+DEPEND="
+ dev-games/physfs
+ dev-libs/boost:=
+ media-libs/glew:0
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2:=
+ media-libs/libsndfile:=
+ media-libs/libvorbis:=
+ media-libs/sdl2-image
+ media-libs/sdl2-ttf
+ media-sound/vorbis-tools
+ openal? ( media-libs/openal )"
+RDEPEND="${DEPEND}
+ games-strategy/colobot-data"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # we need to call it explicitly to help Ninja figure out the deps
+ cd desktop || die
+ po4a po4a.cfg || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEV_BUILD=$(usex devbuild)
+ -DTESTS=$(usex test)
+ -DTOOLS=$(usex tools)
+ -DINSTALL_DOCS=$(usex doc)
+ -DOPENAL_SOUND=$(usex openal)
+ -DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
+ -DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/games-strategy/colobot/colobot-9999.ebuild b/games-strategy/colobot/colobot-9999.ebuild
index 02e4757ef02e..49d5ea90727e 100644
--- a/games-strategy/colobot/colobot-9999.ebuild
+++ b/games-strategy/colobot/colobot-9999.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils desktop
+inherit cmake-utils desktop git-r3 xdg-utils
DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
HOMEPAGE="https://colobot.info/"
+EGIT_REPO_URI="https://github.com/colobot/colobot"
+EGIT_SUBMODULES=()
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/colobot/colobot"
- EGIT_SUBMODULES=()
- inherit git-r3
-else
- SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
-fi
-
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-IUSE="devbuild test tools doc +openal"
+KEYWORDS=""
+IUSE="devbuild doc +openal test tools"
+RESTRICT="!test? ( test )"
+# perl for pod2man
+BDEPEND="
+ app-text/po4a
+ dev-lang/perl
+ sys-devel/gettext"
DEPEND="
dev-games/physfs
dev-libs/boost:=
@@ -34,11 +33,18 @@ DEPEND="
media-libs/sdl2-image
media-libs/sdl2-ttf
media-sound/vorbis-tools
- sys-devel/gettext
openal? ( media-libs/openal )"
RDEPEND="${DEPEND}
games-strategy/colobot-data"
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # we need to call it explicitly to help Ninja figure out the deps
+ cd desktop || die
+ po4a po4a.cfg || die
+}
+
src_configure() {
local mycmakeargs=(
-DDEV_BUILD=$(usex devbuild)
@@ -52,7 +58,10 @@ src_configure() {
cmake-utils_src_configure
}
-src_install() {
- cmake-utils_src_install
- doicon -s 256 desktop/colobot.ico
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
}
diff --git a/games-strategy/colobot/metadata.xml b/games-strategy/colobot/metadata.xml
index e955d3f3c923..f719af210973 100644
--- a/games-strategy/colobot/metadata.xml
+++ b/games-strategy/colobot/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
<upstream>
<remote-id type="github">colobot/colobot</remote-id>
</upstream>