summaryrefslogtreecommitdiff
path: root/games-strategy/augustus
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/augustus')
-rw-r--r--games-strategy/augustus/Manifest6
-rw-r--r--games-strategy/augustus/augustus-3.0.1.ebuild51
-rw-r--r--games-strategy/augustus/files/README.gentoo7
-rw-r--r--games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch11
-rw-r--r--games-strategy/augustus/files/augustus-3.0.1-uncapped.patch16
-rw-r--r--games-strategy/augustus/metadata.xml24
6 files changed, 115 insertions, 0 deletions
diff --git a/games-strategy/augustus/Manifest b/games-strategy/augustus/Manifest
new file mode 100644
index 000000000000..05bf5e890de0
--- /dev/null
+++ b/games-strategy/augustus/Manifest
@@ -0,0 +1,6 @@
+AUX README.gentoo 426 BLAKE2B 803713ea8fe3bd1f20b3a5951cb23135ddb511b916d75ac30c907ef01246a6c365a5f8a50d1a35b1a9e9ca58129828862d2d0b9fc13db5a7e1d3d04071e63957 SHA512 da220fdc16a824044507ea0b69c6e3b165f49e45dc669ab77c79256c271932104293b6e884cd984d7229242113a9431fe77e9ae4e1fd4afc01d68b37399939ae
+AUX augustus-3.0.1-desktop_rename.patch 241 BLAKE2B 8adea277b37e544442cbf38f18387f90d0bf9a3366c5323e2e9bbefda49f517871c173a22dbe937fbf4a1244275c3195f2d008b542c54a778550967726025e7c SHA512 e283524f8e5dafea3bfb890c19be221f586ec6fc70943914eed3d542208c33a4cccf53f06a14fbc8db21be2fdeba6f97b38cea8592a343d11574e094f82cde2e
+AUX augustus-3.0.1-uncapped.patch 464 BLAKE2B 074faedf03b64b3e34c15a9412f3d22f3ec93fa638f9d90e910e2b5c203fe3e608ba29de499cedc22fdad6b19194befa5617bb6aa0e1db230873af554f5082f5 SHA512 725df61a3a21433617a672d62a97ab3f64e3bafbc6e619af8a8959de00b3144ec42c8dff747e846affe3ce74eec4dfdf6cd3613c5c07459df51945598585cf76
+DIST augustus-3.0.1.tar.gz 47539500 BLAKE2B 43e808959f176e4024866074c227814e2be75175cbbca60fbc430a7617941766b8a00ae6f56c08239c5ed8cd60d637109e963eba859c78d60f7b37d54079e7c4 SHA512 4929763a4436863525c4d3f93570090ce066ea2abfe56766d991b7ebc03b34fc53fc8c6dcbb7f5c96e2e10d233bb5966581d148db7d7ea2eac5c1435cc4327bd
+EBUILD augustus-3.0.1.ebuild 1166 BLAKE2B 794f2cf29f9617e329001f9181ce5763cb7b18cf1bc7b7ac3a78c3ff912df89e236928f9837ff3a247a1429090a59d30cb7644437f13ed6b44cc162b8427ccef SHA512 c5c326b5889ed468015cc6648543a3da42a60efb0220dd6e372a58d81c18b33fec3f571da8bd08a5bc1ae6a14ba0edc65c6ceb4bb5075b085b8961822dacf5bd
+MISC metadata.xml 807 BLAKE2B b81e37f70e1351a6e01d33b2cf8791a46bae9b491bf030938e051feb933f0ea5fa73e54e66829ddabbcc2917ecef1fab036708d7937897ce6aa761fb170a23e9 SHA512 1b307d0555a1eb75ba1fd081634506df8c398328c099be0c74e48eac62f303075c6ca5aa18c322c46a63171bca3376349bb7a9b6ab1618d813b2426c4c3641e7
diff --git a/games-strategy/augustus/augustus-3.0.1.ebuild b/games-strategy/augustus/augustus-3.0.1.ebuild
new file mode 100644
index 000000000000..9714036d3284
--- /dev/null
+++ b/games-strategy/augustus/augustus-3.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake readme.gentoo-r1
+
+DESCRIPTION="Feature-enhanced open source re-implementation of Caesar III"
+HOMEPAGE="https://github.com/Keriew/augustus"
+SRC_URI="https://github.com/Keriew/augustus/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="uncapped"
+
+DEPEND="
+ dev-libs/expat
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,video,sound]
+ media-libs/sdl2-mixer
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.1-desktop_rename.patch"
+)
+
+src_prepare() {
+ use uncapped && eapply "${FILESDIR}"/${PN}-3.0.1-uncapped.patch
+ cmake_src_prepare
+}
+
+src_install() {
+ cmake_src_install
+ dodir /usr/libexec
+ mv "${ED}/usr/bin/augustus" "${ED}/usr/libexec/augustus-game" ||
+ die "Failed to rename executable (required to set default resources location)."
+ newbin - augustus-game <<-EOF
+ #!/usr/bin/env sh
+ exec "${EPREFIX}/usr/libexec/augustus-game" "\${1:-\${HOME}/.local/share/julius/app}"
+ EOF
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/games-strategy/augustus/files/README.gentoo b/games-strategy/augustus/files/README.gentoo
new file mode 100644
index 000000000000..f6e9503cd582
--- /dev/null
+++ b/games-strategy/augustus/files/README.gentoo
@@ -0,0 +1,7 @@
+Augustus requires you to download the original Caesar 3 resources.
+
+You need to obtain these files from a vendor of the proprietary software.
+You will then need to copy the 'app' directory into '~/.local/share/julius/app'.
+One way to obtain this directory is to download the GOG Caesar 3 edition.
+You can then produce this directory by installing app-arch/innoextract and running:
+ innoextract -m setup_caesar3_2.0.0.9.exe
diff --git a/games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch b/games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch
new file mode 100644
index 000000000000..662940485795
--- /dev/null
+++ b/games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch
@@ -0,0 +1,11 @@
+--- a/res/augustus.desktop
++++ b/res/augustus.desktop
+@@ -2,7 +2,7 @@
+ [Desktop Entry]
+ Type=Application
+ Version=1.0
+-Exec=augustus
++Exec=augustus-game
+ Icon=com.github.keriew.augustus
+ Name=Augustus
+ GenericName=Roman city management game
diff --git a/games-strategy/augustus/files/augustus-3.0.1-uncapped.patch b/games-strategy/augustus/files/augustus-3.0.1-uncapped.patch
new file mode 100644
index 000000000000..6bd4f93c1a14
--- /dev/null
+++ b/games-strategy/augustus/files/augustus-3.0.1-uncapped.patch
@@ -0,0 +1,16 @@
+From 1d3a24d74bbea85198c2c5d739a16dcc139af18b Mon Sep 17 00:00:00 2001
+From: Horea Christian <chr@chymera.eu>
+Date: Sat, 26 Dec 2020 12:59:15 -0500
+Subject: [PATCH] Unlimited number of Grand Temples.
+
+--- a/src/building/monument.h
++++ b/src/building/monument.h
+@@ -6,7 +6,7 @@
+
+ #define MONUMENT_FINISHED -1
+ #define MONUMENT_START 1
+-#define MAX_GRAND_TEMPLES_PER_CITY 2
++#define MAX_GRAND_TEMPLES_PER_CITY 99
+ #define MARS_OFFERING_FREQUENCY 16
+
+ typedef enum {
diff --git a/games-strategy/augustus/metadata.xml b/games-strategy/augustus/metadata.xml
new file mode 100644
index 000000000000..7318e09e26fe
--- /dev/null
+++ b/games-strategy/augustus/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The aim of this project is to provide enhanced, customizable gameplay
+ to Caesar 3 using project Julius UI enhancements. Augustus is able to
+ load Caesar 3 and Julius saves, however saves made with Augustus will
+ not work outside Augustus.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Keriew/augustus</remote-id>
+ </upstream>
+ <use>
+ <flag name="uncapped">Uncap grand temple count</flag>
+ </use>
+</pkgmetadata>