summaryrefslogtreecommitdiff
path: root/games-sports/trophy/trophy-2.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/trophy/trophy-2.0.3.ebuild')
-rw-r--r--games-sports/trophy/trophy-2.0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-sports/trophy/trophy-2.0.3.ebuild b/games-sports/trophy/trophy-2.0.3.ebuild
new file mode 100644
index 000000000000..ac5132cd9742
--- /dev/null
+++ b/games-sports/trophy/trophy-2.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="2D Racing Game"
+HOMEPAGE="http://trophy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-games/clanlib:0.8[opengl]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ doicon -s 72 "${D}${GAMES_DATADIR}"/icons/${PN}.png
+ rm -rf "${D}${GAMES_DATADIR}"/icons
+ domenu "${D}${GAMES_DATADIR}"/applications/${PN}.desktop
+ rm -rf "${D}${GAMES_DATADIR}"/applications
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}