summaryrefslogtreecommitdiff
path: root/games-simulation/senken/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/senken/files')
-rw-r--r--games-simulation/senken/files/senken-0.3.0-as-needed.patch24
-rw-r--r--games-simulation/senken/files/senken-0.3.0-warnings.patch31
2 files changed, 55 insertions, 0 deletions
diff --git a/games-simulation/senken/files/senken-0.3.0-as-needed.patch b/games-simulation/senken/files/senken-0.3.0-as-needed.patch
new file mode 100644
index 000000000000..428cbc9ee4c6
--- /dev/null
+++ b/games-simulation/senken/files/senken-0.3.0-as-needed.patch
@@ -0,0 +1,24 @@
+diff -ru senken-0.3.0.orig/server/Makefile.in senken-0.3.0/server/Makefile.in
+--- senken-0.3.0.orig/server/Makefile.in 2003-11-20 02:30:15.000000000 -0500
++++ senken-0.3.0/server/Makefile.in 2014-10-30 10:58:51.202157036 -0400
+@@ -10,7 +10,7 @@
+
+ DEFS = @DEFS@
+ CPPFLAGS = -I$(srcdir)/../lib -I$(srcdir) -I$(srcdir)/.. @CPPFLAGS@
+-LIBS = ../lib/libsenken.a @LIBS@ @LIBINTL@
++LIBS = ../lib/libsenken.a @LIBS@ @LIBINTL@ -lm
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+diff -ru senken-0.3.0.orig/src/Makefile.in senken-0.3.0/src/Makefile.in
+--- senken-0.3.0.orig/src/Makefile.in 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/Makefile.in 2014-10-30 10:59:05.154704393 -0400
+@@ -8,7 +8,7 @@
+
+ DEFS = @DEFS@
+ CPPFLAGS = -I$(srcdir)/../lib -I$(srcdir) -I$(srcdir)/.. @CPPFLAGS@ @GTK_CFLAGS@
+-LIBS = ../lib/libsenken.a @LIBS@ @GTK_LIBS@
++LIBS = ../lib/libsenken.a @LIBS@ @GTK_LIBS@ -lm
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/games-simulation/senken/files/senken-0.3.0-warnings.patch b/games-simulation/senken/files/senken-0.3.0-warnings.patch
new file mode 100644
index 000000000000..b15565ad0a90
--- /dev/null
+++ b/games-simulation/senken/files/senken-0.3.0-warnings.patch
@@ -0,0 +1,31 @@
+diff -ru senken-0.3.0.orig/server/protocol.c senken-0.3.0/server/protocol.c
+--- senken-0.3.0.orig/server/protocol.c 2003-11-20 02:30:15.000000000 -0500
++++ senken-0.3.0/server/protocol.c 2014-10-30 11:04:39.831848871 -0400
+@@ -294,7 +294,7 @@
+ /*
+ * If transaction active just save this for later
+ */
+- if (connection_txn_active) {
++ if (connection_txn_active(conn)) {
+ set_op_t *op = calloc(1, sizeof(set_op_t));
+ int r;
+
+diff -ru senken-0.3.0.orig/src/gtkhelp_reports.c senken-0.3.0/src/gtkhelp_reports.c
+--- senken-0.3.0.orig/src/gtkhelp_reports.c 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/gtkhelp_reports.c 2014-10-30 11:06:43.795828908 -0400
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdk.h>
+
+diff -ru senken-0.3.0.orig/src/main.c senken-0.3.0/src/main.c
+--- senken-0.3.0.orig/src/main.c 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/main.c 2014-10-30 11:06:28.147336339 -0400
+@@ -25,6 +25,7 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <gtk/gtk.h>