summaryrefslogtreecommitdiff
path: root/games-simulation/openrct2/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/openrct2/files')
-rw-r--r--games-simulation/openrct2/files/openrct2-0.2.4-disable-desktop-and-icon-files-without-gui.patch52
-rw-r--r--games-simulation/openrct2/files/openrct2-0.2.4-disable-optional-features.patch87
-rw-r--r--games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch20
3 files changed, 20 insertions, 139 deletions
diff --git a/games-simulation/openrct2/files/openrct2-0.2.4-disable-desktop-and-icon-files-without-gui.patch b/games-simulation/openrct2/files/openrct2-0.2.4-disable-desktop-and-icon-files-without-gui.patch
deleted file mode 100644
index cddbe7a93a32..000000000000
--- a/games-simulation/openrct2/files/openrct2-0.2.4-disable-desktop-and-icon-files-without-gui.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 9df66b1f1f56427d896263728c84009c8c3b842b Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conrad@kostecki.com>
-Date: Sun, 10 Nov 2019 20:05:51 +0100
-Subject: [PATCH] CMakeLists.txt: don't install desktop and icon files without
- GUI (#10206)
-
-If OpenRCT2 is compiled without GUI (for example as a dedicated server),
-it does not make sense to install the desktop and icon files.
-
-Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
----
- CMakeLists.txt | 28 +++++++++++++++-------------
- 1 file changed, 15 insertions(+), 13 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7dda401bbdd..f6e4683c9b7 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -319,18 +319,20 @@ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/g2.dat" DESTINATION "${CMAKE_INSTALL_
- install(DIRECTORY "data/" DESTINATION "${CMAKE_INSTALL_DATADIR}/openrct2")
- install(FILES ${DOC_FILES} DESTINATION "${CMAKE_INSTALL_DOCDIR}")
- install(FILES "distribution/linux/openrct2.appdata.xml" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/metainfo")
--install(FILES "resources/logo/icon_x16.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/16x16/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x24.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/24x24/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x32.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/32x32/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x48.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/48x48/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x64.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/64x64/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x96.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/96x96/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x128.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/128x128/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_x256.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/256x256/apps" RENAME "openrct2.png")
--install(FILES "resources/logo/icon_flag.svg" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/scalable/apps" RENAME "openrct2.svg")
--install(FILES "distribution/linux/openrct2.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
--install(FILES "distribution/linux/openrct2-savegame.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
--install(FILES "distribution/linux/openrct2-scenario.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
--install(FILES "distribution/linux/openrct2-uri.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
-+if (NOT DISABLE_GUI)
-+ install(FILES "resources/logo/icon_x16.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/16x16/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x24.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/24x24/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x32.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/32x32/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x48.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/48x48/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x64.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/64x64/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x96.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/96x96/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x128.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/128x128/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_x256.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/256x256/apps" RENAME "openrct2.png")
-+ install(FILES "resources/logo/icon_flag.svg" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/scalable/apps" RENAME "openrct2.svg")
-+ install(FILES "distribution/linux/openrct2.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
-+ install(FILES "distribution/linux/openrct2-savegame.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
-+ install(FILES "distribution/linux/openrct2-scenario.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
-+ install(FILES "distribution/linux/openrct2-uri.desktop" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications")
-+endif()
- install(FILES "distribution/linux/openrct2-mimeinfo.xml" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/mime/packages/" RENAME "openrct2.xml")
- install(DIRECTORY "distribution/man/" DESTINATION "${CMAKE_INSTALL_MANDIR}/man6" FILES_MATCHING PATTERN "*.6")
diff --git a/games-simulation/openrct2/files/openrct2-0.2.4-disable-optional-features.patch b/games-simulation/openrct2/files/openrct2-0.2.4-disable-optional-features.patch
deleted file mode 100644
index 03d6496bf3ee..000000000000
--- a/games-simulation/openrct2/files/openrct2-0.2.4-disable-optional-features.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From fef1906d0d7050b1dfa3792f6e8d3a9b9632df68 Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conrad+github@kostecki.com>
-Date: Sat, 9 Nov 2019 21:20:16 +0100
-Subject: [PATCH] CMakeLists.txt: make discord-rpc and google benchmark
- optional (#10208)
-
-For a package maintainer, it should be possible to disable the support
-for discord-rpc and google benchmark, as it currently always includes them,
-when the library if found.
----
- CMakeLists.txt | 26 +++++++++++++++-----------
- src/openrct2/CMakeLists.txt | 18 ++++++++++--------
- 2 files changed, 25 insertions(+), 19 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ea4bdfd8221..7dda401bbdd 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -42,6 +42,8 @@ CMAKE_DEPENDENT_OPTION(DOWNLOAD_REPLAYS "Download replays during installation."
- option(STATIC "Create a static build.")
- option(USE_MMAP "Use mmap to try loading rct2's data segment into memory.")
-
-+option(DISABLE_DISCORD_RPC "Disable Discord-RPC support." OFF)
-+option(DISABLE_GOOGLE_BENCHMARK "Disable Google Benchmarks support." OFF)
- option(DISABLE_HTTP_TWITCH "Disable HTTP and Twitch support.")
- option(DISABLE_NETWORK "Disable multiplayer functionality. Mainly for testing.")
- option(DISABLE_TTF "Disable support for TTF provided by freetype2.")
-@@ -125,17 +127,19 @@ if (CXX_WARN_SUGGEST_FINAL_METHODS)
- add_definitions(-D__WARN_SUGGEST_FINAL_METHODS__)
- endif ()
-
--if(EXISTS "${ROOT_DIR}/discord-rpc")
-- # Don't build discord's examples, some of which are in C and do not honour
-- # the flags we set for C++. Also we don't use the provided examples.
-- set(BUILD_EXAMPLES OFF CACHE BOOL "Build example apps")
-- add_subdirectory("${ROOT_DIR}/discord-rpc")
-- add_definitions(-D__ENABLE_DISCORD__)
-- include_directories("${ROOT_DIR}/discord-rpc/include")
-- set(HAVE_DISCORD_RPC TRUE)
-- message("Building with discord-rpc support")
--else()
-- message("No discord-rpc detected, to enable clone discord-rpc to root directory: ${ROOT_DIR}")
-+if (NOT DISABLE_DISCORD_RPC)
-+ if(EXISTS "${ROOT_DIR}/discord-rpc")
-+ # Don't build discord's examples, some of which are in C and do not honour
-+ # the flags we set for C++. Also we don't use the provided examples.
-+ set(BUILD_EXAMPLES OFF CACHE BOOL "Build example apps")
-+ add_subdirectory("${ROOT_DIR}/discord-rpc")
-+ add_definitions(-D__ENABLE_DISCORD__)
-+ include_directories("${ROOT_DIR}/discord-rpc/include")
-+ set(HAVE_DISCORD_RPC TRUE)
-+ message("Building with discord-rpc support")
-+ else()
-+ message("No discord-rpc detected, to enable clone discord-rpc to root directory: ${ROOT_DIR}")
-+ endif()
- endif()
-
- # Copied from https://github.com/opencv/opencv/blob/dcdd6af5a856826fe62c95322145731e702e54c5/cmake/OpenCVDetectCXXCompiler.cmake#L63-L70
-diff --git a/src/openrct2/CMakeLists.txt b/src/openrct2/CMakeLists.txt
-index 61be3d13c2a..97674911c0c 100644
---- a/src/openrct2/CMakeLists.txt
-+++ b/src/openrct2/CMakeLists.txt
-@@ -73,14 +73,16 @@ if (NOT DISABLE_TTF)
- endif ()
- endif ()
-
--find_package(benchmark 1.4 QUIET)
--if (benchmark_FOUND)
-- message("Found Google benchmark, enabling support")
-- set_target_properties(${PROJECT_NAME} PROPERTIES COMPILE_DEFINITIONS USE_BENCHMARK)
-- target_link_libraries(${PROJECT_NAME} benchmark::benchmark)
-- target_include_directories(${PROJECT_NAME} PRIVATE ${benchmark_INCLUDE_DIRS})
--else ()
-- message("Google benchmark not found, disabling support")
-+if (NOT DISABLE_GOOGLE_BENCHMARK)
-+ find_package(benchmark 1.4 QUIET)
-+ if (benchmark_FOUND)
-+ message("Found Google benchmark, enabling support")
-+ set_target_properties(${PROJECT_NAME} PROPERTIES COMPILE_DEFINITIONS USE_BENCHMARK)
-+ target_link_libraries(${PROJECT_NAME} benchmark::benchmark)
-+ target_include_directories(${PROJECT_NAME} PRIVATE ${benchmark_INCLUDE_DIRS})
-+ else ()
-+ message("Google benchmark not found, disabling support")
-+ endif ()
- endif ()
-
- # Third party libraries
diff --git a/games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch b/games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch
new file mode 100644
index 000000000000..f0805f408552
--- /dev/null
+++ b/games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch
@@ -0,0 +1,20 @@
+From 8feab6138724722146b1c6d521431556686068d3 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Wed, 19 Aug 2020 22:56:51 +0200
+Subject: [PATCH] ReplayTests: Add support for >=gtest-1.10
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ test/tests/ReplayTests.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/test/tests/ReplayTests.cpp b/test/tests/ReplayTests.cpp
+index 653aa97657f..1443d1c862d 100644
+--- a/test/tests/ReplayTests.cpp
++++ b/test/tests/ReplayTests.cpp
+@@ -117,4 +117,5 @@ struct PrintReplayParameter
+ }
+ };
+
++GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(ReplayTests);
+ INSTANTIATE_TEST_CASE_P(Replay, ReplayTests, testing::ValuesIn(GetReplayFiles()), PrintReplayParameter());