summaryrefslogtreecommitdiff
path: root/games-simulation/flightgear/files/flightgear-2020.1.2-boost.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/flightgear/files/flightgear-2020.1.2-boost.patch')
-rw-r--r--games-simulation/flightgear/files/flightgear-2020.1.2-boost.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/games-simulation/flightgear/files/flightgear-2020.1.2-boost.patch b/games-simulation/flightgear/files/flightgear-2020.1.2-boost.patch
new file mode 100644
index 000000000000..43e2a7d0cb13
--- /dev/null
+++ b/games-simulation/flightgear/files/flightgear-2020.1.2-boost.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -515,7 +515,7 @@
+ set(NOMINMAX 1)
+ endif(WIN32)
+
+-set (BOOST_CXX_FLAGS "-DBOOST_BIMAP_DISABLE_SERIALIZATION")
++set (BOOST_CXX_FLAGS "-DBOOST_BIMAP_DISABLE_SERIALIZATION -DBOOST_NO_STDLIB_CONFIG")
+
+ # append the SIMD flags if requested
+ if (ENABLE_SIMD)