summaryrefslogtreecommitdiff
path: root/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
index f32c81a4c523..2885d6f78f0c 100644
--- a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
+++ b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop
+inherit autotools desktop
DESCRIPTION="Model-airplane flight simulation program"
HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
@@ -28,16 +28,19 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-overlink.patch
)
DOCS=( AUTHORS HISTORY )
-src_configure() {
- econf ac_cv_header_portaudio_h=$(usex portaudio)
+src_prepare() {
+ default
+
+ eautoreconf
}
-src_compile() {
- emake CGAL_LIBS=
+src_configure() {
+ econf ac_cv_header_portaudio_h=$(usex portaudio)
}
src_install() {