summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch')
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch b/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch
new file mode 100644
index 000000000000..d57fa953ad05
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.64-cmake_lua_detection.patch
@@ -0,0 +1,11 @@
+--- a/CorsixTH/CMakeLists.txt
++++ b/CorsixTH/CMakeLists.txt
+@@ -103,7 +103,7 @@
+ endif()
+
+ # Find Lua
+-find_package(Lua REQUIRED)
++find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ if(Lua_FOUND)
+ target_link_libraries(CorsixTH ${LUA_LIBRARY})
+ include_directories(${LUA_INCLUDE_DIR})