summaryrefslogtreecommitdiff
path: root/games-rpg/the-longest-journey-hd/the-longest-journey-hd-1.02.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/the-longest-journey-hd/the-longest-journey-hd-1.02.ebuild')
-rw-r--r--games-rpg/the-longest-journey-hd/the-longest-journey-hd-1.02.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-rpg/the-longest-journey-hd/the-longest-journey-hd-1.02.ebuild b/games-rpg/the-longest-journey-hd/the-longest-journey-hd-1.02.ebuild
new file mode 100644
index 000000000000..54d0ddf85af8
--- /dev/null
+++ b/games-rpg/the-longest-journey-hd/the-longest-journey-hd-1.02.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="1463M"
+CHECKREQS_DISK_USR="1461M"
+inherit check-reqs
+
+DESCRIPTION="High definition backgrounds and sprites for The Longest Journey"
+HOMEPAGE="https://tljhd.github.io"
+SRC_URI="TLJHD_${PV}.zip"
+LICENSE="fairuse"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist fetch"
+
+RDEPEND="
+ ${CATEGORY}/${PN%-hd}
+"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ insinto /usr/share/${PN%-hd}
+ # The fonts are the same as the original ones.
+ doins -r mods/
+}