summaryrefslogtreecommitdiff
path: root/games-roguelike/zangband/zangband-2.7.4c.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/zangband/zangband-2.7.4c.ebuild')
-rw-r--r--games-roguelike/zangband/zangband-2.7.4c.ebuild59
1 files changed, 31 insertions, 28 deletions
diff --git a/games-roguelike/zangband/zangband-2.7.4c.ebuild b/games-roguelike/zangband/zangband-2.7.4c.ebuild
index 23fcdc425c07..211bb818327b 100644
--- a/games-roguelike/zangband/zangband-2.7.4c.ebuild
+++ b/games-roguelike/zangband/zangband-2.7.4c.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils games
+inherit autotools
DESCRIPTION="An enhanced version of the Roguelike game Angband"
HOMEPAGE="http://www.zangband.org/"
SRC_URI="ftp://ftp.sunet.se/pub/games/Angband/Variant/ZAngband/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="Moria"
SLOT="0"
@@ -20,44 +21,46 @@ RDEPEND="
dev-lang/tk:0=
)
x11-libs/libXaw"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
-S=${WORKDIR}/${PN}
+DOCS=( readme z_faq.txt z_update.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tk85.patch
+ "${FILESDIR}"/${P}-rng.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-tk85.patch \
- "${FILESDIR}"/${P}-rng.patch \
- "${FILESDIR}"/${P}-tinfo.patch \
- "${FILESDIR}"/${P}-configure.patch \
- "${FILESDIR}"/${P}-makefile.patch
+ default
+
mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- egamesconf \
- --datadir="${GAMES_DATADIR_BASE}" \
- --with-setgid="${GAMES_GROUP}" \
- --without-gtk \
+ local myconf=(
+ --libdir="${EPREFIX}"/$(get_libdir)/${PN}
+ --with-setgid="nobody"
+ --without-gtk
$(use_with tk tcltk)
+ )
+
+ econf "${myconf[@]}"
}
src_install() {
- # Keep some important dirs we want to chmod later
- keepdir "${GAMES_DATADIR}"/${PN}/lib/{apex,user,save,bone,info,xtra/help,xtra/music}
-
# Install the basic files but remove unneeded crap
- emake DESTDIR="${D}/${GAMES_DATADIR}"/${PN}/ installbase
- rm "${D}${GAMES_DATADIR}"/${PN}/{angdos.cfg,readme,z_faq.txt,z_update.txt}
+ emake DESTDIR="${D}/usr/" installbase
+ rm "${ED}"/usr/{angdos.cfg,readme,z_faq.txt,z_update.txt} || die
# Install everything else and fix the permissions
- dogamesbin zangband
- dodoc readme z_faq.txt z_update.txt
- find "${D}${GAMES_DATADIR}/zangband/lib" -type f -exec chmod a-x \{\} +
-
- prepgamesdirs
- # All users in the games group need write permissions to
- # some important dirs
- fperms -R g+w "${GAMES_DATADIR}"/zangband/lib/{apex,data,save,user}
+ dobin zangband
+
+ einstalldocs
}