summaryrefslogtreecommitdiff
path: root/games-roguelike/adom/adom-3.3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/adom/adom-3.3.3-r1.ebuild')
-rw-r--r--games-roguelike/adom/adom-3.3.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-roguelike/adom/adom-3.3.3-r1.ebuild b/games-roguelike/adom/adom-3.3.3-r1.ebuild
new file mode 100644
index 000000000000..3104784a259b
--- /dev/null
+++ b/games-roguelike/adom/adom-3.3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}_linux_debian"
+
+DESCRIPTION="Ancient Domains Of Mystery rogue-like game"
+HOMEPAGE="https://www.adom.de/"
+SRC_URI="x86? ( https://www.adom.de/home/download/current/${MY_P}_32_${PV}.tar.gz -> ${P}_x86.tar.gz )
+ amd64? ( https://www.adom.de/home/download/current/${MY_P}_64_${PV}.tar.gz -> ${P}_amd64.tar.gz )"
+S="${WORKDIR}"/adom
+
+LICENSE="adom"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip" # The executable is pre-stripped
+
+QA_FLAGS_IGNORED="/opt/bin/adom"
+RDEPEND="sys-libs/ncurses-compat:5[abi_x86_32(-)]"
+
+DOCS=( "docs/adomfaq.txt" "docs/credits.txt" "docs/manual.txt" "docs/readme1st.txt" )
+
+src_install() {
+ exeinto /opt/bin
+ doexe adom
+
+ einstalldocs
+}