summaryrefslogtreecommitdiff
path: root/games-puzzle/xye/xye-0.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/xye/xye-0.12.2.ebuild')
-rw-r--r--games-puzzle/xye/xye-0.12.2.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/games-puzzle/xye/xye-0.12.2.ebuild b/games-puzzle/xye/xye-0.12.2.ebuild
index dd5d31b2b2a0..1dec87af8d3b 100644
--- a/games-puzzle/xye/xye-0.12.2.ebuild
+++ b/games-puzzle/xye/xye-0.12.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools xdg
+inherit autotools eapi8-dosym xdg
DESCRIPTION="Free version of the classic game Kye"
HOMEPAGE="http://xye.sourceforge.net/"
@@ -12,23 +12,23 @@ SRC_URI="mirror://sourceforge/xye/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
media-fonts/dejavu
media-libs/libsdl[video]
- media-libs/sdl-ttf
- media-libs/sdl-image[png]"
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf"
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-0.12.2-fix-buildsystem.patch
- "${FILESDIR}"/${PN}-0.12.2-fix-c++14.patch
- "${FILESDIR}"/${PN}-0.12.2-fix-desktop-file.patch
+ "${FILESDIR}"/${P}-fix-buildsystem.patch
+ "${FILESDIR}"/${P}-fix-c++14.patch
+ "${FILESDIR}"/${P}-fix-desktop-file.patch
)
src_prepare() {
default
+
mv configure.{in,ac} || die
eautoreconf
}
@@ -37,6 +37,6 @@ src_install() {
default
# create symlinks for previously bundled fonts
- dosym /usr/share/fonts/dejavu/DejaVuSans.ttf /usr/share/${PN}/res/DejaVuSans.ttf
- dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf /usr/share/${PN}/res/DejaVuSans-Bold.ttf
+ dosym8 -r /usr/share/{fonts/dejavu,${PN}/res}/DejaVuSans.ttf
+ dosym8 -r /usr/share/{fonts/dejavu,${PN}/res}/DejaVuSans-Bold.ttf
}