summaryrefslogtreecommitdiff
path: root/games-puzzle/torrent/torrent-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/torrent/torrent-0.8.2.ebuild')
-rw-r--r--games-puzzle/torrent/torrent-0.8.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-puzzle/torrent/torrent-0.8.2.ebuild b/games-puzzle/torrent/torrent-0.8.2.ebuild
new file mode 100644
index 000000000000..ca645a95b595
--- /dev/null
+++ b/games-puzzle/torrent/torrent-0.8.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Match rising tiles to score as many points as possible before the tiles touch the top of the board"
+HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
+SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/torrent.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}