summaryrefslogtreecommitdiff
path: root/games-puzzle/tint/tint-0.03b-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/tint/tint-0.03b-r1.ebuild')
-rw-r--r--games-puzzle/tint/tint-0.03b-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-puzzle/tint/tint-0.03b-r1.ebuild b/games-puzzle/tint/tint-0.03b-r1.ebuild
index 4b2d9dc72843..bd16b91c4bbf 100644
--- a/games-puzzle/tint/tint-0.03b-r1.ebuild
+++ b/games-puzzle/tint/tint-0.03b-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
MY_P="${P/-/_}"
DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
@@ -15,14 +17,17 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5.4-r1:0="
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-ovflfix.patch )
src_compile() {
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
emake \
STRIP=true \
CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
+ LDLIBS="$(${PKGCONFIG} --libs ncurses)" \
localstatedir="/var/lib"
}