summaryrefslogtreecommitdiff
path: root/games-puzzle/textmaze/textmaze-1.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/textmaze/textmaze-1.2-r1.ebuild')
-rw-r--r--games-puzzle/textmaze/textmaze-1.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-puzzle/textmaze/textmaze-1.2-r1.ebuild b/games-puzzle/textmaze/textmaze-1.2-r1.ebuild
new file mode 100644
index 000000000000..959e94bd77ec
--- /dev/null
+++ b/games-puzzle/textmaze/textmaze-1.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${PN}_v${PV}
+DESCRIPTION="An ncurses-based maze solving game written in Perl"
+HOMEPAGE="http://robobunny.com/projects/textmaze/html/"
+SRC_URI="http://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Curses"
+DEPEND=""
+
+S="${WORKDIR}/TextMaze"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s#/usr/local/bin/perl#/usr/bin/perl#" \
+ textmaze || die
+}
+
+src_install() {
+ dobin textmaze
+ einstalldocs
+}