summaryrefslogtreecommitdiff
path: root/games-puzzle/skladnik/skladnik-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/skladnik/skladnik-0.5.1.ebuild')
-rw-r--r--games-puzzle/skladnik/skladnik-0.5.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-puzzle/skladnik/skladnik-0.5.1.ebuild b/games-puzzle/skladnik/skladnik-0.5.1.ebuild
new file mode 100644
index 000000000000..32ac7b494dc5
--- /dev/null
+++ b/games-puzzle/skladnik/skladnik-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm kde.org
+
+DESCRIPTION="The Japanese warehouse keeper sokoban game"
+HOMEPAGE="https://invent.kde.org/games/skladnik"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/libkdegames-22.12.0:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="media-gfx/povray"