summaryrefslogtreecommitdiff
path: root/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild')
-rw-r--r--games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
new file mode 100644
index 000000000000..c8b350a1c9fd
--- /dev/null
+++ b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
+HOMEPAGE="http://www.naskita.com/linux/penguzzle/penguzzle.shtml"
+SRC_URI="http://www.naskita.com/linux/${PN}/${PN}.zip"
+
+LICENSE="penguzzle"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/tk
+ dev-tcltk/tclx"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_prepare() {
+ sed -i \
+ -e "s:~/puzz/images:${GAMES_DATADIR}/${PN}:" \
+ lib/init \
+ || die "sed init failed"
+ sed -i \
+ -e "s:~/puzz/lib:$(games_get_libdir)/${PN}:" \
+ bin/${PN} \
+ || die "sed ${PN} failed"
+
+ epatch "${FILESDIR}"/${P}-tclx.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins images/img0.gif
+
+ insinto "$(games_get_libdir)"/${PN}
+ doins lib/init
+
+ dogamesbin bin/${PN}
+
+ dodoc README
+ prepgamesdirs
+}