summaryrefslogtreecommitdiff
path: root/games-puzzle/lmarbles/lmarbles-1.0.8-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/lmarbles/lmarbles-1.0.8-r2.ebuild')
-rw-r--r--games-puzzle/lmarbles/lmarbles-1.0.8-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/lmarbles/lmarbles-1.0.8-r2.ebuild b/games-puzzle/lmarbles/lmarbles-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..0e294386e905
--- /dev/null
+++ b/games-puzzle/lmarbles/lmarbles-1.0.8-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Puzzle game inspired by Atomix and written in SDL"
+HOMEPAGE="http://lgames.sourceforge.net/LMarbles/"
+SRC_URI="
+ https://download.sourceforge.net/lgames/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/gamestat
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( src/manual/. )
+
+src_configure() {
+ econf --localstatedir="${EPREFIX}"/var/games
+}
+
+src_install() {
+ default
+
+ fowners :gamestat /usr/bin/${PN} /var/games/lmarbles.prfs
+ fperms g+s /usr/bin/${PN}
+ fperms 660 /var/games/lmarbles.prfs
+
+ # gif format is not valid for XDG icons, and .desktop hardcodes icon path
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} LMarbles
+ rm "${ED}"/usr/share/{applications/${PN}.desktop,icons/lmarbles48.gif} || die
+}