summaryrefslogtreecommitdiff
path: root/games-puzzle/gnome-sudoku/gnome-sudoku-45.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gnome-sudoku/gnome-sudoku-45.4.ebuild')
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-45.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-45.4.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-45.4.ebuild
new file mode 100644
index 000000000000..16fef17ca527
--- /dev/null
+++ b/games-puzzle/gnome-sudoku/gnome-sudoku-45.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Test your logic skills in this number grid puzzle"
+HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku https://gitlab.gnome.org/GNOME/gnome-sudoku"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgee:0.8=[introspection]
+ >=gui-libs/gtk-4.10.0[introspection]
+ >=gui-libs/libadwaita-1.4_alpha[introspection,vala]
+ dev-libs/json-glib
+ >=dev-libs/qqwing-1.3.4:=
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}