summaryrefslogtreecommitdiff
path: root/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/galaxis/galaxis-1.8-r1.ebuild')
-rw-r--r--games-puzzle/galaxis/galaxis-1.8-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-puzzle/galaxis/galaxis-1.8-r1.ebuild b/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
index 73020c4a91e1..d646f5a94a2b 100644
--- a/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
+++ b/games-puzzle/galaxis/galaxis-1.8-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Curses-based clone of the nifty little Macintosh freeware game Galaxis"
HOMEPAGE="http://www.catb.org/~esr/galaxis/"
@@ -14,9 +16,15 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5.3:0="
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_compile() {
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
+ emake TERMLIB="$(${PKGCONFIG} --libs ncurses)"
+}
+
src_install() {
dobin galaxis
doman galaxis.6