summaryrefslogtreecommitdiff
path: root/games-puzzle/five-or-more/five-or-more-3.32.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/five-or-more/five-or-more-3.32.2-r1.ebuild')
-rw-r--r--games-puzzle/five-or-more/five-or-more-3.32.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-puzzle/five-or-more/five-or-more-3.32.2-r1.ebuild b/games-puzzle/five-or-more/five-or-more-3.32.2-r1.ebuild
new file mode 100644
index 000000000000..e918e6934401
--- /dev/null
+++ b/games-puzzle/five-or-more/five-or-more-3.32.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Remove colored balls from the board by forming lines"
+HOMEPAGE="https://wiki.gnome.org/Apps/Five%20or%20more"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libgee:0.8=
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.20:3
+ dev-libs/libgnome-games-support:1=
+ >=gnome-base/librsvg-2.32:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ gnome-base/librsvg:2[vala]
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}