summaryrefslogtreecommitdiff
path: root/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild')
-rw-r--r--games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild b/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild
new file mode 100644
index 000000000000..1b3790d034ef
--- /dev/null
+++ b/games-puzzle/cuyo/cuyo-2.1.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+# This version (2.~-1.1) should've been 2_pre11 or so, i.e. >=2.0.0 is newer.
+# Optimally need upstream to release >=2.1.2, or will need own custom version.
+MY_P="${PN}-$(ver_cut 1).~-$(ver_cut 2-3)"
+
+DESCRIPTION="Highly addictive and remotely related to tetris"
+HOMEPAGE="https://www.karimmi.de/cuyo/"
+SRC_URI="https://savannah.nongnu.org/download/cuyo/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer[mod]
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc6.patch
+)