summaryrefslogtreecommitdiff
path: root/games-puzzle/construo/construo-0.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/construo/construo-0.2.3.ebuild')
-rw-r--r--games-puzzle/construo/construo-0.2.3.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-puzzle/construo/construo-0.2.3.ebuild b/games-puzzle/construo/construo-0.2.3.ebuild
index 89c4de46b053..740a6c5787db 100644
--- a/games-puzzle/construo/construo-0.2.3.ebuild
+++ b/games-puzzle/construo/construo-0.2.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools desktop toolchain-funcs
DESCRIPTION="2d construction toy with objects that react on physical forces"
@@ -12,12 +13,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="
- media-libs/freeglut
+RDEPEND="media-libs/freeglut
virtual/glu
virtual/opengl
- x11-libs/libXxf86vm
-"
+ x11-libs/libXxf86vm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
@@ -32,11 +31,12 @@ src_prepare() {
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
}
src_install() {
default
- make_desktop_entry "${PN}.glut" "${PN}.glut"
- make_desktop_entry "${PN}.x11" "${PN}.x11"
+
+ make_desktop_entry ${PN}.glut ${PN}.glut
+ make_desktop_entry ${PN}.x11 ${PN}.x11
}