summaryrefslogtreecommitdiff
path: root/games-puzzle/biniax2
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/biniax2')
-rw-r--r--games-puzzle/biniax2/Manifest6
-rw-r--r--games-puzzle/biniax2/biniax2-1.30-r1.ebuild42
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-build.patch18
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch60
-rw-r--r--games-puzzle/biniax2/files/biniax2.xpm41
-rw-r--r--games-puzzle/biniax2/metadata.xml8
6 files changed, 175 insertions, 0 deletions
diff --git a/games-puzzle/biniax2/Manifest b/games-puzzle/biniax2/Manifest
new file mode 100644
index 000000000000..574da8e3dffc
--- /dev/null
+++ b/games-puzzle/biniax2/Manifest
@@ -0,0 +1,6 @@
+AUX biniax2-1.30-build.patch 529 BLAKE2B 4c1a391a9d4534d83b017962c62d8cc776cf44a53f942d468f5e033287158ad7781451a174901e06103f73af216eb1792bb0f18f7941367c2ba9d1d2eaf7ec63 SHA512 3f335b2e71c81f46298c188a1cd3fc5e74210ddb79c4ec514156bfc581125aaf3aaee792f1f86b2b87edc6f8507cee577d817d3c15ce6691c45624c9def11b50
+AUX biniax2-1.30-dotfiles.patch 1372 BLAKE2B 2e33067d9fa951d371093ef33c61303e93760707730ce513f951235b3dad0ff146c6b8132f722da29ec05c61fb5a50eeb58e92ea50251a09e56bfcbd538a1b19 SHA512 7cc2c04ee62931038afe7b89eaeffef33e7e9312a206b987817760c6537c1923945634243abc380b059fc332d12b220d83660f5158f832d1dadb854dc1ea5fa3
+AUX biniax2.xpm 1292 BLAKE2B de60ee16f9229155b2a31682f759b025822eed85bfbe2b7c3d83cd18df230dd3a62bff7d5a5c11e496715a4e3565bee1e565cfbfae15b634993a3c26ec29b070 SHA512 5a53233b27f5e8dd792cd697d8233c8d34adaf00dda51944caad186deb50311e55bd76916f4aa6e352973fe14855d34a27bcf9a91a8f6a56238f5fe18f5d3b58
+DIST biniax2-1.30-fullsrc.tar.gz 3072220 BLAKE2B 7a62f9cf625e7f7d59ac6b84528911f939e489da131a7b414fcdc7cb4acffe1877363983a190aacbc2ce8ca87ae5a631ecc1f9bc937c103b65b6c0543c3cb641 SHA512 180564b24051b629c29bc6245664a36b7ff9881ac5003b03b91eeebff86c89b9507c028c1155387c42debaa51482d8f1e2b08e9e9236b77da1c3f286b78be8b5
+EBUILD biniax2-1.30-r1.ebuild 805 BLAKE2B e3277770de490616fa92e5e2f6bfac4f469a2ae6c31726f9e6e1818702a39248026550c7c4282df0a224d298ba8717e4d44facc43868159e81fcb33f0788f87d SHA512 d8f89846c14ff7232284a097032674d164ede3ce12b563be2a0afce5305deddcd1c460f42f299d798da235c56e098c31ee376dda47b0e41f190f5c3968a3b245
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/biniax2/biniax2-1.30-r1.ebuild b/games-puzzle/biniax2/biniax2-1.30-r1.ebuild
new file mode 100644
index 000000000000..e4710407e8e7
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://mordred.dir.bg/biniax/${P}-fullsrc.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ rm -f data/Thumbs.db
+ sed -i \
+ -e "s:data/:/usr/share/${PN}/:" \
+ desktop/{gfx,snd}.c \
+ || die
+ eapply \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-dotfiles.patch
+}
+
+src_install() {
+ dobin ${PN}
+ insinto "/usr/share/${PN}"
+ doins -r data/*
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+}
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-build.patch b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
new file mode 100644
index 000000000000..cce8abe91a93
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
@@ -0,0 +1,18 @@
+--- a/makefile
++++ b/makefile
+@@ -4,7 +4,7 @@
+ # To execute the game you need the runtimes of SDL, SDL_mixer and SDL_image.
+
+ FLAGS=-W -WALL
+-CC=gcc
++CC?=gcc
+ FILES=biniax.c hof.c desktop/cfg.c desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c
+ INCLUDES=-I . -I desktop
+ LINKTO=-lSDL -lSDL_mixer -lSDL_image
+@@ -12,4 +12,4 @@
+ TARGET=biniax2
+
+ biniax:
+- $(CC) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
+\ No newline at end of file
++ $(CC) $(CFLAGS) $(LDFLAGS) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
new file mode 100644
index 000000000000..00391677ce8a
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
@@ -0,0 +1,60 @@
+--- a/biniax.c
++++ b/biniax.c
+@@ -47,6 +47,8 @@
+ INCLUDES
+ ******************************************************************************/
+
++#include <unistd.h>
++
+ #include "game.h"
+ #include "lev.h"
+ #include "inc.h"
+@@ -97,6 +99,8 @@
+ UNREF( argc );
+ UNREF( argv );
+
++ chdir( getenv( "HOME" ) );
++
+ cfgInit();
+ hofInit();
+ if ( gfxInit() == BNX_FALSE )
+--- a/desktop/cfg.c
++++ b/desktop/cfg.c
+@@ -36,7 +36,7 @@
+ ******************************************************************************/
+
+ #define _Cfg_Buffer 255
+-#define csConfigName "config.bnx2"
++#define csConfigName ".config.bnx2"
+
+ struct BNX_SETUP
+ {
+--- a/game.h
++++ b/game.h
+@@ -37,7 +37,7 @@
+ DEFINITIONS
+ ******************************************************************************/
+
+-#define csSaveGameName "autosave.bnx2"
++#define csSaveGameName ".autosave.bnx2"
+
+ /******************************************************************************
+ CONSTANTS
+--- a/hof.c
++++ b/hof.c
+@@ -34,7 +34,7 @@
+ #define chCursor '_' /* Cursor ON */
+ #define chSpace ' ' /* Cursor OFF*/
+
+-#define csHOFName "hof.bnx2" /* File name */
++#define csHOFName ".hof.bnx2" /* File name */
+ #define cHOFFileSize 504 /* File size */
+
+ BNX_HALL Hof;
+@@ -292,4 +292,4 @@
+ BNX_HALL *hofGet()
+ {
+ return (BNX_HALL *) &Hof;
+-}
+\ No newline at end of file
++}
diff --git a/games-puzzle/biniax2/files/biniax2.xpm b/games-puzzle/biniax2/files/biniax2.xpm
new file mode 100644
index 000000000000..da3c5ddd7d1d
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2.xpm
@@ -0,0 +1,41 @@
+/* XPM */
+static char * icon_xpm[] = {
+"32 32 6 1",
+" c None",
+". c #800000",
+"+ c #FF8204",
+"@ c #FC4E04",
+"# c #FCA204",
+"$ c #FEC489",
+" ",
+" ",
+" ",
+" . ",
+" ++++++++++ .@. ",
+" +########$ .@@@$ ",
+" +#$$$$$$$$ $@$ ",
+" +#$ $ ",
+" +#$ ",
+" +#$ ",
+" +#$ ++++ +++ +++ ",
+" +#$ +#### +#$ +#$ ",
+" +#$ +####+ +#$ +#$ ",
+" +#$ +#$#### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ ######$ +#$ ",
+" +#$ +#$ $####$ +#$ ",
+" +#$ +#$ ####$ +#$ ",
+" $$$ $$$ $$$$ +#$ ",
+" +#$ ",
+" +#$ ",
+" . +#$ ",
+" .@. ++++++++#$ ",
+" .@@@$ +########$ ",
+" $@$ $$$$$$$$$$ ",
+" $ ",
+" ",
+" "};
diff --git a/games-puzzle/biniax2/metadata.xml b/games-puzzle/biniax2/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/biniax2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>