summaryrefslogtreecommitdiff
path: root/games-mud/mudix/mudix-4.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/mudix/mudix-4.3-r2.ebuild')
-rw-r--r--games-mud/mudix/mudix-4.3-r2.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/games-mud/mudix/mudix-4.3-r2.ebuild b/games-mud/mudix/mudix-4.3-r2.ebuild
index 067ddf344613..26a95dbd9298 100644
--- a/games-mud/mudix/mudix-4.3-r2.ebuild
+++ b/games-mud/mudix/mudix-4.3-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="A small, stable MUD client for the console"
HOMEPAGE="http://dw.nl.eu.org/mudix.html"
@@ -12,15 +14,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sys-libs/ncurses:0"
-RDEPEND=${DEPEND}
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-tinfo.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_compile() {
- emake -C src O_FLAGS="${CFLAGS}"
+ emake O_FLAGS="${CFLAGS}"
}
src_install () {