summaryrefslogtreecommitdiff
path: root/games-misc/sex/sex-1.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/sex/sex-1.0-r3.ebuild')
-rw-r--r--games-misc/sex/sex-1.0-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-misc/sex/sex-1.0-r3.ebuild b/games-misc/sex/sex-1.0-r3.ebuild
new file mode 100644
index 000000000000..fddaf87ed5f3
--- /dev/null
+++ b/games-misc/sex/sex-1.0-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Spouts silly mad-lib-style porn-like text"
+HOMEPAGE="http://spatula.net/software/sex/"
+SRC_URI="http://spatula.net/software/sex/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="!sci-astronomy/sextractor"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-Add-missing-string.h-for-strcmp.patch
+)
+
+src_prepare() {
+ default
+
+ rm -f Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake sex
+}
+
+src_install() {
+ dobin sex
+ doman sex.6
+ dodoc README
+}