summaryrefslogtreecommitdiff
path: root/games-misc/sdljoytest/sdljoytest-11102003.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/sdljoytest/sdljoytest-11102003.ebuild')
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
index 8519be5e1834..50d329f815ea 100644
--- a/games-misc/sdljoytest/sdljoytest-11102003.ebuild
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -1,26 +1,25 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="SDL app to test joysticks and game controllers"
HOMEPAGE="http://sdljoytest.sourceforge.net/"
SRC_URI="mirror://sourceforge/sdljoytest/SDLJoytest-GL-${PV}.tar.bz2"
+S="${WORKDIR}"/SDLJoytest-GL
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libsdl[joystick,opengl,video]
virtual/opengl
media-libs/sdl-image"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/SDLJoytest-GL
-
-PATCHES=("${FILESDIR}"/${P}-no-common.patch)
+PATCHES=( "${FILESDIR}"/${P}-no-common.patch )
src_prepare() {
default
@@ -31,7 +30,7 @@ src_prepare() {
src_compile() {
emake \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}"
}