summaryrefslogtreecommitdiff
path: root/games-misc/openmsx/openmsx-0.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/openmsx/openmsx-0.4.2.ebuild')
-rw-r--r--games-misc/openmsx/openmsx-0.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-misc/openmsx/openmsx-0.4.2.ebuild b/games-misc/openmsx/openmsx-0.4.2.ebuild
new file mode 100644
index 000000000000..dc361cd1968b
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1
+
+DESCRIPTION="Open source music base set for OpenTTD"
+HOMEPAGE="https://wiki.openttd.org/en/Basesets/OpenMSX https://github.com/OpenTTD/OpenMSX"
+SRC_URI="https://cdn.openttd.org/openmsx-releases/${PV}/${P}-source.tar.xz"
+S="${WORKDIR}/${P}-source"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+# Don't appear to be meaningful
+RESTRICT="test"
+
+BDEPEND="${PYTHON_DEPS}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_install() {
+ insinto /usr/share/openttd/baseset/${P}
+ doins ${P}/{*.mid,openmsx.obm}
+ dodoc ${P}/{changelog,readme}.txt
+}