summaryrefslogtreecommitdiff
path: root/games-misc/opengfx
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/opengfx')
-rw-r--r--games-misc/opengfx/Manifest6
-rw-r--r--games-misc/opengfx/metadata.xml3
-rw-r--r--games-misc/opengfx/opengfx-0.6.1.ebuild (renamed from games-misc/opengfx/opengfx-0.6.0.ebuild)17
3 files changed, 14 insertions, 12 deletions
diff --git a/games-misc/opengfx/Manifest b/games-misc/opengfx/Manifest
index ce6aa75e33bb..56afc9481306 100644
--- a/games-misc/opengfx/Manifest
+++ b/games-misc/opengfx/Manifest
@@ -1,3 +1,3 @@
-DIST opengfx-0.6.0-source.tar.xz 9693320 BLAKE2B cb1d25fb038b3b481c0abe206426b5843c2f7b81b7cf81a525ebf8b217359c5ea50c0e1ee1ed37d5093a0186231a1e1b9134624a8b69362f6733c6c13d5e1500 SHA512 275b9040e6938bdd5bee2d39361e0b78f447a8e497cc8ff018c7874dc16a357870f8b560999ebb2f2f0b275644c7c9ce85c964875f5a798e2ec45e62a8bc768f
-EBUILD opengfx-0.6.0.ebuild 1071 BLAKE2B fe484ff55815c0a3637832d27d592678fa5caaf6806958f88563f07d48d85a0b10a4ced7aade17572d2a03c70d2fb754e916b683afcd57388aa95d5d094710ed SHA512 23473534dce3d7c5db504ca0a57f52de1258599c45989056d5342444617f2bcd791fdbb3f1d27589de2b3d72082a7406617ad5826a7d487aeb27799a8e6aede4
-MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
+DIST opengfx-0.6.1-source.tar.xz 9690748 BLAKE2B faa3ca805166a1716f8a235048506620bbb98a4265c72571b3a33e88f3375caff75b5576b64ef451e99dea734145f3be748a9109c7003d1ad9043a90cdd34dad SHA512 4ba3528dbdddea1baa2875f917f959034659c8205fbda2b2a67c5fe80161235d15c25dab323e6da8cba2711b7b4f0c9a96d4187fd2de61ae9a2ff9fd077b063b
+EBUILD opengfx-0.6.1.ebuild 1110 BLAKE2B bc015c7e976e7cc8fe92edd19d21a875972582353d205797d2dc05b865e56c0b97c18ce040e2698c6e3ea397a86fb04b9b84f15d840fe0ad362a0d7c735149db SHA512 e1f79bc2741790dfab53e0c88a8e1412374d329aa8c1bdb517fb588f4322887b1b58c7190098754e7bd88bd55dad72cc04679a1a2e69ffc47062e643631c094c
+MISC metadata.xml 326 BLAKE2B f2a424817b435eaf0c241db3ad7adcd422e78fef505d5630e23c7b3045fcd0db1d0d1578ae6df55a7fb8ecead4e1aec3308a8d48365a69685905fe48e354ee69 SHA512 ed5e54fa519eaf7a5f52c13795996aa1a2f8cf252e03d57ae6a2101750e1896b6b04e81685d439bb5364576c58562e28b44337dff7ea067b309f7e6bb560ad55
diff --git a/games-misc/opengfx/metadata.xml b/games-misc/opengfx/metadata.xml
index 78274e0fa550..60f4cf275b21 100644
--- a/games-misc/opengfx/metadata.xml
+++ b/games-misc/opengfx/metadata.xml
@@ -5,4 +5,7 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+<upstream>
+ <remote-id type="github">OpenTTD/OpenGFX</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/games-misc/opengfx/opengfx-0.6.0.ebuild b/games-misc/opengfx/opengfx-0.6.1.ebuild
index e2ab2499de5a..95f257d71459 100644
--- a/games-misc/opengfx/opengfx-0.6.0.ebuild
+++ b/games-misc/opengfx/opengfx-0.6.1.ebuild
@@ -3,13 +3,12 @@
EAPI=7
-MY_PN="OpenGFX"
PYTHON_COMPAT=( python3_{7..9} )
inherit python-any-r1
DESCRIPTION="OpenGFX data files for OpenTTD"
-HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+HOMEPAGE="https://wiki.openttd.org/en/Basesets/OpenGFX https://github.com/OpenTTD/OpenGFX"
SRC_URI="https://cdn.openttd.org/${PN}-releases/${PV}/${P}-source.tar.xz"
S="${WORKDIR}/${P}-source"
@@ -32,31 +31,31 @@ src_prepare() {
}
src_compile() {
- myemakeargs=(
+ local myemakeargs=(
GIMP=""
- PYHTON="${EPYTHON}"
+ PYTHON="${EPYTHON}"
)
emake "${myemakeargs[@]}" all
}
src_test() {
- myemakeargs=(
+ local myemakeargs=(
GIMP=""
- PYHTON="${EPYTHON}"
+ PYTHON="${EPYTHON}"
)
emake "${myemakeargs[@]}" check
}
src_install() {
- myemakeargs=(
+ local myemakeargs=(
DO_NOT_INSTALL_README="true"
DO_NOT_INSTALL_LICENSE="true"
DO_NOT_INSTALL_CHANGELOG="true"
GIMP=""
- INSTALL_DIR="${ED}/usr/share/games/openttd/data/"
- PYHTON="${EPYTHON}"
+ INSTALL_DIR="${ED}/usr/share/openttd/baseset/"
+ PYTHON="${EPYTHON}"
)
emake "${myemakeargs[@]}" install