summaryrefslogtreecommitdiff
path: root/games-misc/lolcat/lolcat-90.8.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/lolcat/lolcat-90.8.8-r1.ebuild')
-rw-r--r--games-misc/lolcat/lolcat-90.8.8-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-misc/lolcat/lolcat-90.8.8-r1.ebuild b/games-misc/lolcat/lolcat-90.8.8-r1.ebuild
new file mode 100644
index 000000000000..595d34230b67
--- /dev/null
+++ b/games-misc/lolcat/lolcat-90.8.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="lolcat.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rainbows and unicorns!"
+HOMEPAGE="https://github.com/busyloop/lolcat"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/trollop-2.1.2:2
+ >=dev-ruby/paint-2.0.0"
+
+all_ruby_prepare() {
+ sed -i -e '/paint/ s/2.0.0/2.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}