summaryrefslogtreecommitdiff
path: root/games-kids/childsplay
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids/childsplay')
-rw-r--r--games-kids/childsplay/Manifest7
-rw-r--r--games-kids/childsplay/childsplay-0.90.2-r1.ebuild147
-rw-r--r--games-kids/childsplay/files/childsplay4
-rw-r--r--games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch21
-rw-r--r--games-kids/childsplay/metadata.xml15
5 files changed, 194 insertions, 0 deletions
diff --git a/games-kids/childsplay/Manifest b/games-kids/childsplay/Manifest
new file mode 100644
index 000000000000..86962f605752
--- /dev/null
+++ b/games-kids/childsplay/Manifest
@@ -0,0 +1,7 @@
+AUX childsplay 99 BLAKE2B 3b936c64c19529eadd49f1117477bc70bfa3c478b2dc548f6bb60e7caeaf1f8dbdf50c3dd896db14799069eac24175001514fa7e37607f45846a66ec4ed656f8 SHA512 7bdd05a0e957ce09a00443d84332bbeb62016b1df4cc88e693f0714ce9ceae4b5acd4447745c98e75063d5010b27dfb8bbf1f93bf5c3c729ced5edbd4afdfef0
+AUX childsplay-0.90.2-gentoo.patch 895 BLAKE2B dd8ea9ee59ddd57cf0172197247491f91f7b8ad7e7ca0c066ac9b40599aaf8dbad2a692e507fc0c436b9ff2993ed4d6003f3fe9078a616ce02b62b2fde2e9cff SHA512 77fe4151574e0b84218fa973b5f72631b378fb24892ff35902ebc88c9f7bd54129813cb2453551034f58b96bddd79c55c00a074184acf267962c2a737f4392cf
+DIST childsplay-0.90.2.tgz 2330022 BLAKE2B 83370489c52bd62ae46aee6f2d01d5ff42c17887105c5e4b1ba2c9f95c8869b8e315447fe60f6f325d6d6479c7ebf2c82832ffadf4414419976ed1507ed0a889 SHA512 0cc59f893f43f47fec18a6ba04e3d5b4c4b41e6c387fcd64859a65a0660b4d1c8803cd092932fc9d24a4d4b9784d6cc62cc2efc4e841ca62a205f17aec8dec68
+DIST childsplay_plugins-0.90.tgz 4528735 BLAKE2B 1aacd311138c97a868cacca723941ec582ef049831ce1ddb10f2e524f1109ceb81cf4bd34d16f2c857c4ce42ac49f7f5cb9d785e229e11f540476544093e6cb1 SHA512 f1c47c544da364bde6023cf8450d96423d214749f800d783661b6fb16f73c8bbc899ee7f997f36e11b43aff7655332c29445f865ff22dd475ad4ce4a0557e763
+DIST childsplay_plugins_lfc-0.90.tgz 6159653 BLAKE2B eb117a526f6c2caf43578dc0027d8d3b2849529d132ffc55b92d59efbfc12681f31961c265b3f6ab592a17db1a05987458b265bdf68054cef16386b71d2e28a1 SHA512 4fa8f59aae64520de03fd6527dbe7339f320ef377deca19fe91cf5591b364d853cfb9d73b8469417178fcf4bc074d6ed39a1704a20cb5a82657722862c749313
+EBUILD childsplay-0.90.2-r1.ebuild 3914 BLAKE2B 1deb5b73b35c56ed2d07719db6f1aff61760aa2a8660629c68ecbf0ae23e99fc0137c427c1ffb059e669ab3919a8c9bb124759c6c01bb5bc228cb15d73b164d8 SHA512 35e0bde061f8103da30fd1112ad3132fb07f9022a35cc015c9f1f970b1dbd47c5c4186441aece5e5f1e9045af6136b3ca26f93415c134884350018c876a99543
+MISC metadata.xml 516 BLAKE2B 785e9855bda1d0268ce6328d5e01cee50332941fc73203bcb7e85678225df29ad48bc1db13c5ccddb1e6fa1bdf25418a5dc2e840eb220c6b1995cd31ddb73c2d SHA512 145c6baf1c8115b4fbf694360c48e53ab31c32ec2cc2d3b2f9bb159377f4629b827014833155f17468cb5fccc98a8bef1ef8bc6fd64dab39d1d8fdf2b16e9275
diff --git a/games-kids/childsplay/childsplay-0.90.2-r1.ebuild b/games-kids/childsplay/childsplay-0.90.2-r1.ebuild
new file mode 100644
index 000000000000..3c535ad41d94
--- /dev/null
+++ b/games-kids/childsplay/childsplay-0.90.2-r1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="A suite of educational games for young children"
+HOMEPAGE="http://childsplay.sourceforge.net/"
+PLUGINS_VERSION="0.90"
+PLUGINS_LFC_VERSION="0.90"
+SRC_URI="mirror://sourceforge/childsplay/${P}.tgz
+ mirror://sourceforge/childsplay/${PN}_plugins-${PLUGINS_VERSION}.tgz
+ mirror://sourceforge/childsplay/${PN}_plugins_lfc-${PLUGINS_LFC_VERSION}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-image[gif,jpeg,png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+ media-libs/libogg"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ local DIR
+
+ # Copy the plugins into the main package.
+ mv ../${PN}_plugins-${PLUGINS_VERSION}/Data/AlphabetSounds Data || die
+ mv ../${PN}_plugins-${PLUGINS_VERSION}/add-score.py . || die
+ for DIR in ${PN}_plugins-${PLUGINS_VERSION} ${PN}_plugins_lfc-${PLUGINS_LFC_VERSION}; do
+ mv ../${DIR}/Data/*.icon.png Data/icons || die
+ cp -r ../${DIR}/lib/* lib || die
+ mv ../${DIR}/assetml/${PN}/* assetml/${PN} || die
+ rm -rf ../${DIR}
+ done
+ gunzip man/childsplay.6.gz
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ python_fix_shebang .
+}
+
+src_install() {
+ local fn
+
+ # The following variables are based on Childsplay's INSTALL.sh
+ _LOCALEDIR=/usr/share/locale
+ _ASSETMLDIR=/usr/share/assetml
+ _SCOREDIR=${GAMES_STATEDIR}
+ _SCOREFILE=${_SCOREDIR}/childsplay.score
+ _CPDIR=$(games_get_libdir)/childsplay
+ _SHAREDIR=${GAMES_DATADIR}/childsplay
+ _LIBDIR=${_CPDIR}/lib
+ _MODULESDIR=${_LIBDIR}
+ _SHARELIBDATADIR=${_SHAREDIR}/lib
+ _SHAREDATADIR=${_SHAREDIR}/Data
+ _RCDIR=${_SHARELIBDATADIR}/ConfigData
+ _HOME_DIR_NAME=.childsplay
+ _CHILDSPLAYRC=childsplayrc
+
+ dodir \
+ "${_CPDIR}" \
+ "${_LIBDIR}" \
+ "${_SHAREDIR}" \
+ "${_SHARELIBDATADIR}" \
+ "${_SCOREDIR}" \
+ "${_LOCALEDIR}" \
+ "${_ASSETMLDIR}"
+
+ # create BASEPATH.py
+ cat >BASEPATH.py <<EOF
+## Automated file--please do not edit
+LOCALEDIR="${_LOCALEDIR}"
+ASSETMLDIR="${_ASSETMLDIR}"
+SCOREDIR="${_SCOREDIR}"
+SCOREFILE="${_SCOREFILE}"
+CPDIR="${_CPDIR}"
+SHAREDIR="${_SHAREDIR}"
+LIBDIR="${_LIBDIR}"
+MODULESDIR="${_MODULESDIR}"
+SHARELIBDATADIR="${_SHARELIBDATADIR}"
+SHAREDATADIR="${_SHAREDATADIR}"
+RCDIR="${_RCDIR}"
+HOME_DIR_NAME="${_HOME_DIR_NAME}"
+CHILDSPLAYRC="${_CHILDSPLAYRC}"
+EOF
+
+ # copy software and data
+ cp -r *.py "${D}/${_CPDIR}" || die "cp failed"
+ cp -r Data "${D}/${_SHAREDIR}" || die "cp failed"
+ rm "${D}/${_SHAREDIR}/Data/childsplay.score" # this copy won't be used
+
+ for fn in $(ls lib); do
+ if [[ -d lib/${fn} ]] ; then
+ cp -r lib/${fn} "${D}/${_SHARELIBDATADIR}" || die
+ else
+ cp lib/${fn} "${D}/${_LIBDIR}" || die
+ fi
+ done
+
+ if [[ ${LINGUAS+set} ]]; then
+ for lang in $LINGUAS; do
+ [[ -d locale/$lang ]] && cp -r locale/$lang "${D}/${_LOCALEDIR}"
+ done
+ else
+ cp -r locale/* "${D}/${_LOCALEDIR}" || die
+ fi
+ cp -r assetml/* "${D}/${_ASSETMLDIR}" || die
+
+ # initialize the score file
+ cp Data/childsplay.score "${D}/${_SCOREFILE}" || die
+ SCORE_GAMES="Packid,Numbers,Soundmemory,Fallingletters,Findsound,Findsound2,Billiard"
+ ${PYTHON} add-score.py "${D}/${_SCOREDIR}" $SCORE_GAMES
+
+ # translate for the letters game
+ ${PYTHON} letters-trans.py "${D}/${_ASSETMLDIR}" << EOF
+Q
+EOF
+
+ doman man/childsplay.6
+ dodoc doc/README* doc/Changelog doc/copyright
+
+ # Make a launcher.
+ dogamesbin "${FILESDIR}"/childsplay
+ sed -i \
+ -e "s:GENTOO_DIR:${_CPDIR}:" \
+ -e "s:python:${PYTHON}:" \
+ "${D}${GAMES_BINDIR}"/childsplay \
+ || die "sed failed"
+
+ python_optimize "${D}${_CPDIR}"
+
+ newicon assetml/childsplay/childsplay-images/chpl-icon-48.png ${PN}.png
+ make_desktop_entry childsplay Childsplay
+
+ prepgamesdirs
+ fperms g+w "${_SCOREFILE}"
+}
diff --git a/games-kids/childsplay/files/childsplay b/games-kids/childsplay/files/childsplay
new file mode 100644
index 000000000000..eccf016836d0
--- /dev/null
+++ b/games-kids/childsplay/files/childsplay
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -z "${LANGUAGE}" ] && LANGUAGE=en
+export LANGUAGE
+python GENTOO_DIR/childsplay.py "$@"
diff --git a/games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch b/games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch
new file mode 100644
index 000000000000..742e3e02ee3c
--- /dev/null
+++ b/games-kids/childsplay/files/childsplay-0.90.2-gentoo.patch
@@ -0,0 +1,21 @@
+--- letters-trans.py.old 2010-04-26 12:13:12.000000000 +0200
++++ letters-trans.py 2010-04-26 12:13:49.000000000 +0200
+@@ -39,7 +39,7 @@
+ import os,fnmatch,operator,sys,locale
+ from CPConstants import ASSETMLROOT
+
+-if os.environ['USER'] != 'root':
++if os.environ['LOGNAME'] != 'root':
+ print "\nOnly root can use this script, sorry.\n"
+ sys.exit(1)
+
+@@ -69,7 +69,8 @@
+ sys.exit(0)
+
+ # get description names from memory assetml, these are the words used by letters.py
+-parser = pyassetml.AssetmlParser('childsplay/memory-136x136/memory-136x136.assetml')
++assetmlfile = os.path.join(cwd,'memory-136x136.assetml')
++parser = pyassetml.AssetmlParser(assetmlfile)
+ loc = parser.get_locale()# get current locale setting, only the first two chars !!
+ wlist_org = parser.find_names((('file','.'),('description',"en")))
+ wlist = parser.find_names((('file','.'),('description',loc)))
diff --git a/games-kids/childsplay/metadata.xml b/games-kids/childsplay/metadata.xml
new file mode 100644
index 000000000000..56a899baf102
--- /dev/null
+++ b/games-kids/childsplay/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+Childsplay is a suite of educational games for young children, like gcompris,
+but without the overkill of c/c++ and the gnome environ.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">childsplay</remote-id>
+ </upstream>
+</pkgmetadata>