summaryrefslogtreecommitdiff
path: root/games-fps/xonotic
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/Manifest2
-rw-r--r--games-fps/xonotic/xonotic-0.8.1.ebuild117
2 files changed, 0 insertions, 119 deletions
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index c1546daf92dd..dd860cbd1bb4 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,5 +1,3 @@
-DIST xonotic-0.8.1.zip 984854761 BLAKE2B 442e4660903552c65e0dbc552013ae237ab8d0d9278a04e6e1d83f7957e7306ea95f3c0e4c7523823191a4458825ba3813bbd92e43e77448a4b351f0e041edc4 SHA512 adfce546257bdc7cfebe94f53eaa9cc9b19eaa546c6405e31ed6af080e3948732c960a024126202e5853cb98b955daadeeb5a96c602a6d4d83e284d3540214a4
DIST xonotic-0.8.2.zip 991045679 BLAKE2B 3005473da954492bb7387f9e0e13c2415e638877fa8b83e14872f3b04ed0fc21b82e18f51aa6c68e8bf02d09d4a73f290cbcaebdfa8c0a12ceb6582309baee8a SHA512 0787fcf326827ae0292e5917c7ff2c7fd79947209d4b62e7f83b8b828bec15b575da304e0631f9f163c9b0bd93bed13616e142398ff08cbdaaea890a939dfca5
-EBUILD xonotic-0.8.1.ebuild 2613 BLAKE2B e3eb2c42982135d59fc739230a57cb9c50308bbf6630d88526479e5c7dcef02d039df463e567b432fc8ae20ae9eb425fefeae0e8612c45c49a1563a8fdb68740 SHA512 6cf1f27215f87342f6a10c260a524ea2c7e53269a7075358382e9085bc5506e40f958418ebffbe7484fabdaae322e85cc8ce51948cfe67a8a78f1ed537750fe8
EBUILD xonotic-0.8.2.ebuild 2517 BLAKE2B 99d32ebedd391d073be82e4fe3677fe87d8108cc05ebf4ab7c6538aa49579cb7b92542d1945374e2c1896f22790fb8c7dacd99acbf9ad9a6238041edc9586afa SHA512 c4a5d77d19c1570e4c6dd84100f2a2878ce09d7a747a5ec0741c3098c1b05307db94e92d918824a2f1a7cd4bceae6250e71020d672b7b1b79894459eaf2a57af
MISC metadata.xml 351 BLAKE2B a5005814468014cf93d7f807b7f1c5d9252aecf20584267cdef61547d109727230f14c3f21297e202c4876e0534fac7d5ab86022c3741d582115c04b1bcf18f9 SHA512 14665ca256c368cbf80a08aaff18c005a25a4197eae82b559e934fbe6a3b17ef6f1fbd323621e38af5725f3e61ff750c72bb8fe650fb76eeed818070d411e3f6
diff --git a/games-fps/xonotic/xonotic-0.8.1.ebuild b/games-fps/xonotic/xonotic-0.8.1.ebuild
deleted file mode 100644
index d8977b5a0e32..000000000000
--- a/games-fps/xonotic/xonotic-0.8.1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils check-reqs toolchain-funcs games
-
-# Switch to ^ when we switch to EAPI=6.
-MY_PN="X${PN:1}"
-DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
-HOMEPAGE="http://www.xonotic.org/"
-SRC_URI="http://dl.xonotic.org/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa debug dedicated doc ode sdl"
-
-UIRDEPEND="
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/libmodplug
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXpm
- x11-libs/libXext
- x11-libs/libXdmcp
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- virtual/opengl
- media-libs/freetype:2
- alsa? ( media-libs/alsa-lib )
- ode? ( dev-games/ode[double-precision] )
- sdl? ( media-libs/libsdl[X,sound,joystick,opengl,video,alsa?] )"
-UIDEPEND="
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- x11-proto/xproto"
-RDEPEND="
- sys-libs/zlib
- virtual/jpeg:0
- media-libs/libpng:0
- net-misc/curl
- ~dev-libs/d0_blind_id-0.5
- !dedicated? ( ${UIRDEPEND} )"
-DEPEND="${RDEPEND}
- !dedicated? ( ${UIDEPEND} )"
-
-CHECKREQS_DISK_BUILD="1200M"
-CHECKREQS_DISK_USR="950M"
-
-S=${WORKDIR}/${MY_PN}
-
-pkg_pretend() {
- check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- check-reqs_pkg_setup
- games_pkg_setup
-}
-
-src_prepare() {
- sed -i \
- -e "/^EXE_/s:darkplaces:${PN}:" \
- -e "s:-O3:${CFLAGS}:" \
- -e "/-lm/s:$: ${LDFLAGS}:" \
- -e '/^STRIP/s/strip/true/' \
- source/darkplaces/makefile.inc || die
-
- if ! use alsa; then
- sed -i \
- -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
- source/darkplaces/makefile || die
- fi
-}
-
-src_compile() {
- local t="$(use debug && echo debug || echo release)"
- local i
-
- tc-export CC CXX LD AR RANLIB
-
- # use a for-loop wrt bug 473352
- for i in sv-${t} $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})") ; do
- emake \
- -C source/darkplaces \
- DP_LINK_ODE=$(usex ode shared no) \
- DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
- ${i}
- done
-}
-
-src_install() {
- if ! use dedicated; then
- dogamesbin source/darkplaces/${PN}-glx
- newicon misc/logos/${PN}_icon.svg ${PN}.svg
- make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
-
- if use sdl; then
- dogamesbin source/darkplaces/${PN}-sdl
- make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
- fi
- fi
- dogamesbin source/darkplaces/${PN}-dedicated
-
- dodoc Docs/*.txt
- use doc && dohtml -r Docs
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r key_0.d0pk server data
- prepgamesdirs
-
- elog "If you are using opensource drivers you should consider installing: "
- elog " media-libs/libtxc_dxtn"
-}