summaryrefslogtreecommitdiff
path: root/games-fps/ut2004-muralis
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004-muralis')
-rw-r--r--games-fps/ut2004-muralis/Manifest3
-rw-r--r--games-fps/ut2004-muralis/metadata.xml8
-rw-r--r--games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild21
3 files changed, 32 insertions, 0 deletions
diff --git a/games-fps/ut2004-muralis/Manifest b/games-fps/ut2004-muralis/Manifest
new file mode 100644
index 000000000000..d17b08ef7865
--- /dev/null
+++ b/games-fps/ut2004-muralis/Manifest
@@ -0,0 +1,3 @@
+DIST muralis-v1.15-zip.zip 62575050 BLAKE2B e168053472e63507667707295b3bfee261f802017cdd82e3b35b33855747fa19b75c4861f991b7678861cf8bfe84ea00ce697d979cd19c297c05c06b1c87d910 SHA512 b50477e3ef221241a430f95a390e34d5ffee3ea460e62bafa30b534d6499ef1a616d8ca35f77179e8f7a50b5e69f82441cb9779d38e71388c2868add45822330
+EBUILD ut2004-muralis-1.15.ebuild 489 BLAKE2B 2e483fe134a76c22546c53209786eaca5db34733ac57cafeb963aff512b4a34a73c92b4fd2874a1e18c31b2d81308f45e5c0888443902ecbe34e415f175d82f9 SHA512 14476b7cf20ba34492a1084388a63d8010bb78dabc84ea087e35cd418334510aa0d459c7ef611497744d90cd662d714f45d938a089d9cf25cc181ed8d142f845
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/ut2004-muralis/metadata.xml b/games-fps/ut2004-muralis/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/ut2004-muralis/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
new file mode 100644
index 000000000000..70fe77742c3c
--- /dev/null
+++ b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="third-person hand-to-hand single/multiplayer mod"
+MOD_NAME="Muralis"
+MOD_DIR="muralis"
+
+inherit unpacker games games-mods
+
+HOMEPAGE="https://www.moddb.com/mods/muralis"
+SRC_URI="https://ut.rushbase.net/beyondunreal/mods/muralis-v${PV}-zip.zip"
+
+LICENSE="freedist"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+
+src_prepare() {
+ mv -f Muralis ${MOD_DIR} || die
+}