summaryrefslogtreecommitdiff
path: root/games-fps/unreal
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/unreal')
-rw-r--r--games-fps/unreal/Manifest6
-rw-r--r--games-fps/unreal/files/unreal3
-rw-r--r--games-fps/unreal/metadata.xml21
-rw-r--r--games-fps/unreal/unreal-226.ebuild85
4 files changed, 115 insertions, 0 deletions
diff --git a/games-fps/unreal/Manifest b/games-fps/unreal/Manifest
new file mode 100644
index 000000000000..fe23ac1cea90
--- /dev/null
+++ b/games-fps/unreal/Manifest
@@ -0,0 +1,6 @@
+AUX unreal 53 BLAKE2B da95fd3d009a468bed4eb4e26bfc182e92b7d63067df309ee7a69f5a132a46f74335b3ca3ca20dff0902a3a32ec38eb993b55496d0204912397afff41e16faae SHA512 0728ca1599fb289812c99d45801cf0566e9651ecefdd4fe10252e6bde3bc035e7cf1294e34056e35b851dcb0f3826907ffaea60b974f61ce75660d144d5955ce
+DIST IpDrv-436-Linux-08-20-02.zip 105435 BLAKE2B 3b0c960513f3bfdaa5394148978f1258b54cedec0722890fd1d89a81b7c809a9d837f6da0e147f1566ee253ed6fd0c7692d043e50ddd383d99245f7aec3df759 SHA512 5f10152b87cf702225fe50d213f3fbd4865cb2f190e0c2c87c996420c115e5f84de7748af635705b8a2ea789bfeaaab4b927364563a4b83f973dcb5af866ccd7
+DIST unreali-install.run 4118594 BLAKE2B 6c105e0901882b1a04cc7983eaeb60dbe50379579a177d3ccd78f1fafda9c1ed4ab603006f0dfc4faaad4f425ec3f242bd28c09bb91e4a1f07a2dd5ab702cf1a SHA512 9b918fec89de0bb273a2c351dbaccfe32eaaaf9c5ba012ddaf38c1e8617d7c6b8a08c9ac04135105bea89f4127f7f64f52c8d2c00a00e9418f4807fc1f3aff7b
+DIST ut-install-436.run 6225010 BLAKE2B 107a4991db59e1ff800bf2a1e002f0e56f5415b14a936ced149ace57c5359f10b75d0c2506e5fe40dfb2ca28b068cf225b35dda5fae0af84864df4edb560e05a SHA512 cfdeb9f345daef4b81acadfa24d711477ba208dffd50716087d034df2dc1eb0ac5bb03570f4f1701b3c4d46b8f954e6d23dde36fc20dafdc114e68730a1fc932
+EBUILD unreal-226.ebuild 2194 BLAKE2B 6863c259080438a133a86d81fc5e523bdf1123d77b4703420adabaf4803fb8fb9cc57409dfc1d92931e97fcf712f0fd499c617476fe3ff4c756d5a1e0ada82a0 SHA512 fc4dc6962c0b7779fc9dd0bb1dff2fa3e2f0a4d23b2c632a60e32a6e2a907a6e05fe887e4a1745f99385782152a10eeaf7ab852ed92e6bae38cf6b3bf6940125
+MISC metadata.xml 1029 BLAKE2B 66573c17f1f7598f72cf8fae650d16e05dcaeb082e99b7ecbc220bf765cafd2b4e45ead9f0c36d33989a6efedab7bf20e1b851e582de1f63b5733565e430893d SHA512 2a8b13fb3eb26a76f6f9bd0da9d186e05d10ad24112bc74d8b1494768e3360ea6059453e1fe1645df03f8f793f9a6ff695e5754117ecb90054279c960039de95
diff --git a/games-fps/unreal/files/unreal b/games-fps/unreal/files/unreal
new file mode 100644
index 000000000000..7bbeb753fbe9
--- /dev/null
+++ b/games-fps/unreal/files/unreal
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec ./UnrealTournament "$@"
diff --git a/games-fps/unreal/metadata.xml b/games-fps/unreal/metadata.xml
new file mode 100644
index 000000000000..6a1fcf4b013c
--- /dev/null
+++ b/games-fps/unreal/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+In Unreal, players take on the role of a criminal whose transfer ship
+has crashed on the mysterious planet Gryphon, where a peaceful race
+known as the Nali have been hunted and enslaved by bloodthirsty aliens
+called Skaarj. To dominate Gryphon and mine its precious Tarydium, the
+Skaarj command legions of other menacing species like the gigantic
+Titans, the bio-engineered Brutes and the pack-hunting Krall. Unreal
+combatants must survive in the midst of this inter-species warfare
+armed with an array of deadly weapons. Players will visit ancient Nali
+ruins, underground mines, cities in the sky, spacecraft wreckage and
+even the mysterious Skaarj Mothership in this deadly hunt in which
+every character is both predator and prey.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/unreal/unreal-226.ebuild b/games-fps/unreal/unreal-226.ebuild
new file mode 100644
index 000000000000..81318a0aa9f4
--- /dev/null
+++ b/games-fps/unreal/unreal-226.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="Futuristic FPS (a hack that runs on top of Unreal Tournament)"
+HOMEPAGE="http://www.unreal.com/ http://icculus.org/~chunky/ut/unreal/"
+SRC_URI="http://www.icculus.org/%7Echunky/ut/unreal/unreali-install.run
+ ftp://ftp.lokigames.com/pub/patches/ut/ut-install-436.run
+ ftp://ftp.lokigames.com/pub/patches/ut/IpDrv-436-Linux-08-20-02.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X opengl"
+RESTRICT="mirror bindist"
+
+DEPEND="sys-libs/lib-compat
+ app-arch/unzip
+"
+RDEPEND="
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ opengl? ( virtual/opengl[abi_x86_32(-)] )
+"
+
+S=${WORKDIR}
+
+src_unpack() {
+ export CDROM_NAME_1="Unreal CD"
+ export CDROM_NAME_2="Unreal Tournament CD"
+ cdrom_get_cds System/Unreal.ini System/UnrealTournament.ini
+ unpack_makeself unreali-install.run
+ mkdir ut
+ cd ut
+ unpack_makeself ut-install-436.run
+ unpack IpDrv-436-Linux-08-20-02.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/unreal
+ dodir "${dir}"
+
+ tar -zxf ut/data.tar.gz -C "${D}/${dir}"
+ tar -zxf ut/OpenGL.ini.tar.gz -C "${D}/${dir}"
+ tar -zxf System.tar.gz -C "${D}/${dir}"
+ insinto "${dir}"/System
+ doins ut/IpDrv.so
+
+ cp -rf "${CDROM_ROOT}"/{Maps,Music,Sounds} "${D}/${dir}/"
+ for f in "${D}/${dir}"/Maps/Dm*.unr ; do
+ mv "${f}" "${f/Dm/DM-}"
+ done
+ dosym Maps "${dir}"/maps
+
+ if has_version '<games-fps/unreal-tournament-451' \
+ || has_version '<games-fps/unreal-tournament-goty-451' ; then
+ CDROM_ROOT="${GAMES_PREFIX_OPT}/unreal-tournament"
+ else
+ cdrom_load_next_cd
+ fi
+ insinto "${dir}"/Textures
+ doins "${CDROM_ROOT}"/Textures/*.utx
+ insinto "${dir}"/Sounds
+ doins "${CDROM_ROOT}"/Sounds/*.uax
+ insinto "${dir}"/System
+ doins "${CDROM_ROOT}"/System/*.u
+ insinto "${dir}"/Music
+ doins "${CDROM_ROOT}"/Music/*.umx
+
+ insinto "${dir}"
+ doins icon.* README*
+
+ exeinto "${dir}"
+ doexe bin/x86/unreal
+
+ games_make_wrapper unreal ./unreal "${dir}" "${dir}"
+
+ prepgamesdirs
+}